Just started with my vero and need some pointers

I’ve been using this for about a day. Some things are quite neat but it’s become clear that I’m going to have to spend a bit of time getting things working.

One thing that worked well is when I plugged my firefox phone into one of the USB slots it allowed me to browse to the photos and also watch a couple of movie clips I’d made on the device.

I’ve tried to run through updates but it stops every now and then and says

OSMC Update Error: Error Installing: Please report this on the OSMC forum.

I’ve tried going back out and installing updates again and sometimes it seems to run through but I don’t think things are quite right.

The other thing that it tells me to do is to install a PVR Client. I’ve tried a couple of different ones but they don’t seem to be working. I get a message flashing up on the screen saying MediaPortal PVR Client Connection lost

I was hoping to use my prosoloo DVB-T USB card, but I think I may strugge with drivers for it. I used to use it several years ago and maybe it’s become outdated.

If I’m to buy a new DVB card could someone recommend one.

Many thanks


Regarding the Update Error, do you have a working Internet connection on the Vero ?

Have you installed any software via APT or have you just booted it up and run an update ?

Please upload your debug logs using the log uploader function in OSMC settings.

You have likely activated LiveTV by mistake.

A log for the updates will help us find out what’s up


When I hit the upload logs button it says

Could not retrieve URL

Copy logs to SD Card Instead

I guess I’ll do this.

I think the device is connected to my wifi because earlier it was reporting back that it was downloading and was giving me a feedback reading saying 18 kb/s

Not fast I know, but it suggests a connection

Ok I’ve just tried to go back into the network connections section. Wireless network says “no connection”. I’ve disabled the wireless and then enabled it but it can’t seem to pick up my wifi. My wifi is working because I’m writing this on my laptop

OK - I powered down the Vero and turned it back on again. It now allows me to upload my logs. Having said that how will you know they are mine? Should I have noted down the URL at the end?

Yes, we’ll need that URL.


Here’s the URL

http://paste.osmc.io/ tonayuxuxe

Not sure if there’s a space between the last forward slash and the t but it looks like there is so I’ve included it

What I can see in your log file is that your wireless connection disconnected in the middle of checking for updates, at around 22:04:03 in the kodi.log. This will be what caused the Update error. Then at 22:06:04 it reconnected to the wifi.

So the underlying issue is an unreliable wireless connection. Tell us a bit more about your wireless setup, like how far away the router is and what sort of router it is, etc.

My router is a technicolour tg582n pro. It’s about 10m away from the vero

WiFi doesn’t usually drop on other devices at greater distances than that.