Just updated and no image


I’ve got a Vero 4K a few days ago. I connected it to a LCD screen with just an VGA port, using a VGA to HDMI adapter. It ran just fine.

I’ve just updated the OS, and got a black screen and a message saying “Unsupported frequencies”.

I connected to the device via SSH, and it’s working fine, so I guess it’s a screen setup problem. How can I solve this issue?

You could try moving .kodi to reset things while connected with ssh.

$ sudo systemctl stop mediacenter
$ mv .kodi .kodi-save
$ sudo systemctl start mediacenter

Do you have an hdmi screen to test with temporarily to rule out a problem with your adapter?

Thanks, but that didn’t work.

Yes, I tried with another screen with HDMI, and it works. I’ve tried to change the screen resolution, because I suspect that the current resolution is not suported by my VGA monitor, but the screen settings are greyed out, so I can’t change them manually. I uploaded the logs:


OSMC is outputting a 1080p signal.
What mode do you need?

Modes will only be selectable if you a valid EDID is received. This won’t be the case with VGA. However, you can force a mode via the command line. If you’re familiar with SSH and you can clarify the video mode you want, I can provide instructions


I’m not sure, but I think the max resolution that this screen supports is 1280x720. Anyhow, if you can provide me instructions, I can try several modes until it works, maybe starting from 1024x768.

1024x768 isn’t possible at this time.

For 720p, try:

sudo fw_setenv hdmimode 720p50hzforce
sudo fw_setenv outputmode 720p50hzforce
1 Like

Thank you so much, the device is now back to life in my VGA screen.

Excellent. If Vero 4K doesn’t receive display information in a timely fashion, then the options for video modes in Kodi will be limited.

By forcing your display mode you guarantee a 720p50Hz signal will always be displayed if OSMC can’t determine better display capabilities.

Do let us know if there’s anything else we can do