Just updated to 5/2 and get sad face when trying to play movie

Tried multiple times and different movies. Logs are here:

Any help greatly appreciated.

Does this happen with all files or just some?


4K movies seem to play fine but HD movies seem to be hit or miss with most not playing. Either immediately get sad face or after few seconds of playing. Also, the same movie will play one time but then won’t play the next time. All movies are Blu-ray rips to mkv.

Can you reboot and upload a log of:

  • Video working
  • Video not working



Not working

Thanks. I think I see the issue now.

1 Like

Any update on this Sam? Just downloaded some update but still doesn’t work.

I need to see new logs to see what version of osmc you are running now as well as an attempt to play a clip




Please advise.

Sorry – I was travelling today. Looking at this now.

This should already be fixed – do you know how to use SSH?
Alternatively, this will be released as an update shortly.


Yes I can SSH. But if shortly means within next 24 hours I can just wait. Thanks for reply.


I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Ok. I already had deb http://apt.osmc.tv stretch-devel main in my list. Does that mean I am still accessing test builds or something?

I did update and played one movie fine but then crashed on the next one i tried. Logs here:

So are the symptoms the exact same as before?


Yes. 4K UHD movies play fine. HD movies crash.

Hey everybody,

I have been a perfectly happy customer until this started happening after the update :frowning: .
Anyway to rollback easily?

best regards

Can you try and update again? It should now be fixed. Please follow the previous instructions

Already tried 5 minutes ago and now again - no dice. Nothing works Live-TV, TV-Show, Movies…

No update available - which version should be latest?

Edit: I’m on devel by the way…