JustBoom Remote - Middle Button not working

Hi forum!

I recently setup OSMC on my Raspberry Pi 3 and everything went smooth except that my Justboom remote middle button doesnt work while in keyboard mode. When I switch it over to being a mouse it works just fine. Using the mouse function is just frustrating as hell! I can remember that this also happened last summer/spring after I upgraded my previous Raspberry Pi with OSMC and Kodi.

What I have tried is this
#1 Using the keymapper app from the add ons to map the middle button as “Select”. It does pick up that I press the button and create a keymap file, but it does nothing.

key id=“16839168”

#2 Using showkey to figure out if the button pressing is doing anything. It picks this up

keycode 353 press
keycode 353 release

#3 evtest /dev/input/event3 picks up the button while in keyboard mode

Event: time 1583429060.543564, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0041
Event: time 1583429060.543564, type 1 (EV_KEY), code 353 (KEY_SELECT), value 1
Event: time 1583429060.543564, -------------- SYN_REPORT ------------

I am certain that the remote is working, but for some reason it is not being mapped correctly. I am comfortable messing around in the command line through SSH, but I have quite limited knowledge on linux. What can I do to figure this out? Any help is appreciated!

Thanks,
Oskar

I’d suggest checking with Pi-Supply about this as the keymap may need updating. I seem to recall them submitting this via a PR to our repository.

Alternatively, you could use irrecord to create a new keymap.

Thanks for this. I will look into it.

In the mean time, I tried mapping the mute button as Select through the key mapper program and it worked! I dont understand why this is allowed but the middle button not. Is something over riding the gen.xml file or has higher priority?

It’s likely that Pi Supply submitted the keymap with an older version of Kodi in mind.

This is an erroneous result. From what I have been able to gather there is no valid code longer than five digits. This can also happen in Keymap editor if you hold down the button instead of just doing a short press.

I don’t think Kodi can currently pick up a key if this code number is showing more than 255. At least that is how i’m reading this issue…

To fix this I think the key would need to be remapped to “enter” with udev.

Hi all,

I have tried making a file for udev by following the guidelines from Yulistic, but no luck. Note, the inputs changed a bit after I removed an USB mouse

I: Bus=0003 Vendor=2252 Product=0120 Version=0110
N: Name=“HBGIC Technology Co., Ltd. USB Keyboard Mouse Consumer Control”
P: Phys=usb-3f980000.usb-1.2/input1
S: Sysfs=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.1/0003:2252:0120.0002/input/input2
U: Uniq=
H: Handlers=kbd event2

Event: time 1583789613.864361, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0041
Event: time 1583789613.864361, type 1 (EV_KEY), code 353 (KEY_SELECT), value 0

/etc/udev/hwdb.d/60-keyboard.hwdb
evdev:input:b0003v2252p0120e0110*
KEYBOARD_KEY_c0041=enter

Any ideas?

Try…

evdev:input:b0003v2252p0120*
 KEYBOARD_KEY_c0041=enter

Note that there must be exactly one space before the “KEYBOAR…” and the file must not have the execute permission set on it. If your trying to reload it with those update and trigger commands that will probably not work. I had to reboot for it to actually take. You could have probably saved yourself some effort if you replied to the pm I sent you three days ago.

Hi Darwin,

Didnt realize I had a PM until you mentioned it…!

I definitely dont have a space before KEYBOARD_… Do I set the execution permission with chmod 777? I will try this out when I get home tonight and revert back!

Thanks!

Well 777 would set the execution permission and @darwindesign wrote “must not have” so it would be chmod -x <filename>

1 Like

Indeed. This permission would not normally be set if you just used nano and made the file in place. I happened to have copied one of these files from my PC and managed to somehow get that permission set which kept the file from working. I figured it would be prudent to pass along a known failure point.

I will not work without that space.

Yeeehhaaa, the middle button is alive!!!

The missing space was all that was missing! Hopefully this post will help someone else in the future.

Thank you all for the help on this!

1 Like