Keep getting "lock settings" with user/password when adding a smb folder

I have been having some issues in the last few days. I had raspbmc installed and after formating my laptop, i wanted to add the shared folders again but this time i kept getting stuck in a loop of user+password. I thought it was some issue with raspbmc and thought i would give osmc a try, so i installed it and still the same problem. Even added that smb “addon” from the osmc app store to try but nothing.

I have the master lock disabled; i shared the folders with read/write privalage to the user i created for the Pi, i tried with and without password on windows, and nothing.

Anyone knows how to fix this? I found more people, even from few years ago, with the same problems and they either ended up not getting a response or fix or the fix they had didnt work on my case.

Thank you!

If you are lucky, someone may be able to answer your question, even tho’ you have given little pertinent information.
If I have made the correct inferences, and the share is not on the RPi, then installing the smb module will avail nothing as this gives you the server module, and the client module is already installed and usable from square one.

1 Like

Thank you!
Your guess is right. The folder with the files i want to stream to the pi is on my laptop. What i usually do is select the folder, share it with a user i made for the rpi on windows with read/write permissions, browse on the rpi to my computer, insert the user and password from the user i created on windows and then i have the folder(s) i want on my rpi.This always worked until a few days ago where after formating the laptop and doing this process, it keeps me on that “lock settings” window to type the password and user.

Im sorry about the lack of info on my first post.Is there anything else more specific i should post?

You could try posting full logs from RPi/OSMC, after turning on debug, rebooting, and re-trying the connect, but I suspect that it is at the Windows end that you need to change things - I thought this even before I read that you had re-formatted the laptop.
Can you capture, and post, the screen showing the ‘lock settings’ window - I don’t recognise the description.

1 Like

Im not home right now, but when i get there i will try the log/debug mode. The screenshot i found one online that shows that window Link
It might be something indeed on windows end, since i used an old raspbmc build before and even installing the most recent osmc didn’t solve it. I can’t think of what it could be though, i don’t remember doing anything different and i have installed this set up more than once.

OK - that seems an odd title for the window, since it relates to username and password for the share.
I really couldn’t advise further, since it all seems to revolve around settings at the Windows end - BTW you never said which version of Windows you are using, and that might hold the key to more meaningful advice.
In the past I’ve sorted my own problems with the help of google searches, and some of the steps are a bit involved.

1 Like

I did seem to forget to mention a few basic things indeed. im sorry. Im running windows 7 home premium.
I checked the log and the error it ends up giving is that the user doesn’t exist =/ which is strange since i do have it created just for xbmc and the folders shared on windows for that user(so i have 2 accounts on the laptop, mine that i use for everything and then one that i don’t log in that is just called xbmc, i read at the time someone advised to have sperate accounts for some reason). However, i just tried the username and password for my pc account (non-xbmc dedicated one) that im loged into now and was able to enter and see the folders i wanted.
Its definitly something strange on windows side. I think i will just leave it like this then and remove the xbmc dedicated account on my laptop.

[quote=“sgriffin, post:7, topic:5022”]
I think i will just leave it like this then and remove the xbmc dedicated account on my laptop.
[/quote] Sounds like a good idea if you want to have it working quickly.
Without more details on exactly what you set up and tried, I can only sugget things like firewalls, differences on how Windows treats names by default (we used to have to put stuff in caps for smb in Windows) and detailed setting of permissions for the share folders and files.

Hello there fellow Kodi lovers. This ‘Lock preferences for smb’ problem has driven me mental over the past week and I finally cracked it. I’m on Windows 10 and Kodi 16.1 ‘Jarvis’. Trying to access shared drives on my Windows laptop resulted in asking for login details…like others here, nothing worked. So here’s the fix I finally settled on.
In ‘My Computer’, right click the drive to access- properties- Security tab. Click Edit- Add and in the box type Everyone. Click OK- Apply. I think. if you’re security conscious, you can select Read only here but I didn’t try that. Go back to Kodi and select the share and no login will be required. Bingo !!
Hope this helps.

Hi everyone, I was lucky to get this info from other blog and it works for me so far.
Hope it will also work for you.

I have Windows 10 and Kodi 16.1 Jarvis. All my shared folders on windows 10 were working until several days ago. All of sudden, I received the “locked preference…” with user name and password display. One of suggestion that I tried and I got it working… thanks.
I created an username “xbmc” on the windows 10 computer with any password.
In the share folder setting, use “advance Sharing” , add permission and Security access to “xbmc” with at least “read” permission. Somehow, only this particular
“xbmc” account will work. I even tried the windows 10 administrator account but no luck. After I re-added the source in Kodi and I still receive the “lock preference…”
Just enter the “xmbc” username and password. It went thru.

Hope this solution works for your, too. I have been having this headache for several days and I hope others doesn’t have to go thru the same thing.

I have a PI 2 that I set up a couple years ago, no issues with it and it still works today. Got a Pi 3 a couple weeks ago and had the exact Lock Preferences issue. Here is what I did to get it connected to my home computer files:

  1. Windows button and “X”

  2. Computer Management

  3. Local Users and Groups

  4. Right click on user folder, select add new user

  5. I added the user called Kodi Pi3 and the description of “Kodi Pi3 access to home computer shares”. The new user is a member of “users” group. Set the password you want, save and restart the computer.

Now when I wend back into the Pi3 (running LibreElec/Jarvis), created a new SMB network location to my home computer (SMB:// Was prompted for a user name and password, entered the new one I just created and BINGO! Everything as is should be in the world and I can now stream the video and music to the PI.

Not to say any other option here would not work, I just didn’t want to change the security setting for the whole computer.

Hopefully this helps you out.