Kernel module for TerraTec Cinnergy S2 USB box


I want to watch satellite TV via OSMC on a raspberry 3 (actually, I’m unsure, if this is a raspberry 3, I tend to forget version numbers. It is running kernel rbp2-4.4.27-5-osmc). Therefore, I recently bought a DVB-S tuner, the TerraTec Cinnergy S2 USB Box. Apparently, my stick is Revision 4 of this product and not yet supported by the kernel. The usb code is 0ccd:0105.
There is a kernel module (based on liplianin kernel source) available from the (German speaking) forum that is reported to work on Ubuntu and Raspbian.
In particular, this is a DKMS package provided (look at the code parts of this post that include dropbox download links )and I found out that DKMS packages unfortunately do not work under OSMC (same error as here).

I would be happy to compile the kernel module on my own but I do not know where to start. Unfortunately, the tutorial about this is not available anymore.

Could you give me helping pointers how to unzip the DKMS package and manually build and install the kernel module?
Of course, I would also be happy, if you could include the driver into the official version of OSMC.

Keep up the great work!

DKMS is a bad idea for OSMC where we bump the kernel significantly.

If you can find a modern driver package you could look at including it in the OSMC kernel. The device would have to be pretty popular though. There is also a chance that the driver would be dropped in a future version if we could not maintain it.

For Pi, we will soon move to 4.10. It is worth checking if the driver has since been mainlined

I think, the device is supported in 4.10, if I read the corresponding files correct.
What means “soon” in this context? I’m asking because depending on the time estimate, I might want to try to compile it manually (or just wait some weeks? months?)

4.10 is still in the RC stages.

The plan is to move to it when it is released. Probably around March 2017. You could build it manually for now, but you may have to update some patches for this to build.

I don’t want to bother you too much, but I saw that the latest update still sticks to kernel 4.4.
I guess you were probably too busy with updating and fixing Kodi Krypton related stuff (which is running fine, thanks for all your efforts, I appreciate it!).
Could you nevertheless give a rough time estimate when kernel 4.10 will arrive in OSMC? DVB-T will be switched off here soon, and I’d like to use DVB-S then.
Is there maybe a beta build with 4.10 available?

We will move to 4.9 as it’s LTS, rather than 4.10 when it’s ready

okay, this should work with my device also. Do you know roughly when you will move to 4.9?

When it’s ready. There are no rough estimates.

Hey there,

thanks for the latest update that included the 4.9 kernel. The DVB-S tuner now seems to work (reasoning from tvheadends webinterface). However, the remote control that comes with the tuner box does not work.
Nothing happens at Kodi’s interface, and running irrecord also does not work.
I tried several things but it seems that somehow lirc does not recognize this remote properly.
When stoping kodi and eventlircd, I can see that in principle the remote does work, because ir-keytable -t shows output when I press buttons.
I do not see this kind of output for any other tool.
Here is some information about the remote from ir-keytable:

Found /sys/class/rc/rc0/ (/dev/input/event1) with:
	Driver dw2102, table rc-tt-1500
	Supported protocols: RC-5 
	Enabled protocols: 
	Name: IR-receiver inside an USB DVB re
	bus: 3, vendor/product: 0ccd:0105, version: 0x0000
	Repeat delay = 500 ms, repeat period = 125 ms

Where should I start to get a working remote control?

Many thanks!

It seems to look like that tuner only supports RC5 remote controls.

Are you trying to use an RC5 remote?
You will need to record your remote’s profile using irrecord if it’s not found in My OSMC -> Remotes.

Sorry, I have no clue of these abbreviations, RC5, RC6, NEC, CEC, you name it. :smirk:
So, yes, it seems that I am trying to use an RC5 remote.

I tried to use irrecordto train the new remote (it’s not in the Kodi GUI), but this does not work at all. Even though I ran

sudo systemctl stop mediacenter
sudo systemctl stop eventlircd

before trying, irrecord does not capture any key presses from the remote.

But, interestingly, an old remote (that still works in Kodi!) is neither captured by irrecord.
This old remote comes with a different (DVB-T) TV tuner I’d like to get rid of.
I’m not home now, but the output from ir-keytable -t had for this different remote as Supported protocols: NEC, RC-5, RC-6. Crucially, there was also an entry under Enabled Protocols, I think it was NEC or RC-6 and the name of the kernel driver/module (?) em28xx.

Keypresses from both remotes are recognized when running ir-keytable -t, so the kernel detects them and in principle they are usable. Inspired by this blog-post: Can I anyhow disable lirc completely to rule out that it is conflicting with the kernel remote setup?

I think the problem is your receiver only supports RC5

Consider a GPIO (TSOP) based receiver instead


Okay, and RC5 is not supported by Kodi or OSMC in general?
Because it seems to be supported by the current OSMC 4.9 kernel, as ir-keytable -t responds to button presses on the remote (but they just don’t happen to be reflected in Kodi).

I’d rather like to use the already present remote (thats part of the TV tuner kit) than buying a new one …

RC5 is supported by OSMC and we pass interpreted presses to Kodi.

Use irrecord to create an LIRC profile.

As I wrote above, irrecord does not work – it does not capture any keypress (even not of a remote that works in Kodi) and times out after 10 secs.
Is there a more comprehensive guide for the use of irrecord around?

Did you stop Kodi and the LIRC helper service first?

Is there anything more I would need to do?

Stop the lircd_helper service.

sorry, sam, but this does not work.

I’ve stopped all lirc-related processes:

> ps -ax | grep lirc
 1084 pts/0    S+     0:00 grep lirc

But irrecord -f -d /dev/lirc0 remote.conf still gives

irrecord: no data for 10 secs, aborting
irrecord: gap not found, can't continue

All this with the remote that works in Kodi …

Starting the eventlircd service again and running irw works for this remote (hooray), but fails for the new remote I want to use.