Keyboard media keys not working

as per the title the media keys, play, stop, volume up ect do not work logs included

its on a fresh install of the most recent image on a rpi3

Please restart your device, play one track and then press each of those keys in turn , (I have play/pause, voldown, volup and mute on my keyboard) stop the track with X or the stop button and upload the log.

What make/model is your keyboard?

this keyboard is branded as alba but i have a few others that act the same,

none of the media keys have any effect what so ever, i tried using the keymap editor and it does not register that a key has been pressed.

if i exit to the command line show key reacts and gives me key numbers when i press the offending keys when i press the keys

Enable Kodi debug logging (System > System Settings > Logging) then open an ssh session to the box. From the command line run: tail -f /home/osmc/.kodi/temp/kodi.log and try some keypresses. If they are detected, you’ll see them appearing on the screen.

the problem is they are not detected under kodi

with the keyboard plugged it if i run evtest there are two inputs event0 and event1, the normal keyboard keys are run off event0 and all work, the multimedia keys are on event1 the keys work in evtest but do no seem to be picked up by osmc

FWIW my keyboard (Microsoft wired 600) also uses two Handlers event8 and event9 but media keys work fine.

yeah i have another wireless keyboard that acts the same 2 event handlers for different keys, evtest gives the same results for both keyboards but osmc works works with the second keyboard. so im not sure why its ignoring the events from one keyboard

I just use the shortcut keys. On one of my kbs you need to use Fn for the media keys - spacebar, X, F9/F10 is easier!

this keyboard has no fn key just the media keys, for play pause ect at the top, it would make the user experience a lot easier for some one less tech savvy if they worked as expected.

any clues where to look as to why osmc is not grabbing the inputs?