Killing sd cards?

Today I tried to apply an update and it failed and hung halfway through with etx4 errors. I powered off the pi and tried to wipe the card in windows and linux via gparted. It seems like nothing will write to the card. Is this card dead?
The card is a Samsung evo 16gb and only about 6 months old.

Check your power supply.

What’s the exact error when using the official OSMC installer? Print Screen would be useful

It’s not the Pi or the OSMC that kills the Card they, the Evo dies all alone, lost 2 of them and several other lost one too, just search in the Forum.

Would you still go with the Evo for price/performance/reliability or is there another brand you would go with?

Atm I use an Sandisk Ultra

Samsung, SanDisk or the official OSMC one are good bets:

I also lost two Samsung Evo cards. Nothing compares to their speed, but sooner or later they crash and burn and can no longer be revived.

I am curious whether the same applies to the Evo+ series, will probably get one to test.

As you can imagine, I use a lot of SD cards for compiling and testing. I’ve not had any problems with SanDisk or our cards, and some of these cards have been compiling 4-5 hours a day for over three years. When you’re compiling, 4K write performance is really important.


If You want SD card which will last long search one with “Wear leveling” … it’s something like TRIM in SSD :slight_smile:
Cheap cards doesn’t have this so when You often write small files You may destroy a sector (those have limited write cycles)

Don’t think it’s Samsung’s intention to market the Evo series as cheap. Athough, since they’ve recently also started to sell phones which explode, you never know :slight_smile:

Clearly with fridge problems too, they’re building an ecosystem :wink:

I have a Raspberry Pi B, 2, and 3. I used a cheap SD card on the B and a samsung 32GB EVO Class 10 on my newer models. On all three I opted to use the install to USB option and put it on a “Patriot 32GB Supersonic Rage Series 3.0” including my Pi B that I first set up back in February 2015 (back in the Raspbmc Days). All three of these have had extensive use and still continue to work flawlessly. I know that someone suggested wear leveling which is good too but for $16 on amazon, just buy the USB drive. They are way more versatile than Mini or Micro SD cards. I have yet to have any issues with any of my devices doing that way.

May both in combination would make a really heavy detonation, we need one to try it.

Have you tried windows sd card formatter?

Yeah, I have used windows, diskpart, gparted, dd, and rufus.

I think he actually means this

No, i haven’t used that, but I could give it a shot.

Had a Samsung evo card with same problems as yours. Tried everything to get it to format nothing worked. You could transfer files to the card but once you eject card files are gone. I read on Amazon there were a few fake evo cards going around. I think a genuine card if u look at the back is made in Korea or Philippines plus it should have a white strip on side of card.

In the end I just chucked it in bin. so far new evo card working good.

H2Testw is the standard for testing capacity and likelihood of a genuine card.