Kodi 17.1.0-1 will not update

Get error clicking osmc in kodi so then I tried the back door and used sudo apt-get update/sudo apt-get dist-upgrade didn’t work :frowning:

What should I do next ?


Looks fine.

When you say it doesn’t work? What did you get as a result of running dist-upgrade?

After using dpkg -l | grep mediacenter-osmc | awk ‘{ print $3 }’ it still shows 17.1.0-1 and I still cant launch OSMC in Kodi

Oh – you mean you have an issue opening My OSMC?

Can you post a Kodi debug log of you opening it?

yes service fails to launch

Isnt that a Debug log in the first post ?


Your system is quite broken.

My OSMC won’t work because Python seems broken on your system.

You’ve also installed bluetooth package, but this isn’t a good idea as it will conflict with OSMC’s Bluetooth implementation.

I would recommend a reinstallation. We can’t really support the number of changes you’ve made to your system.


It was the only bluetooth driver that worked PS3 controller for Retropie. Oh well I will start over
Thank you

Probably better for us to get things working as expected in OSMC instead of hacking around this

You can probably back up and Restore without any issues

So, what package is that (the “OSMC’s Bluetooth implementation”)? armv7-bluez-osmc? Shouldn’t it have a ‘Conflicts:’ and/or ‘Breaks:’ on bluetooth then, to avoid breakage?



Yes, and no.

The problem is we can’t provide Conflicts, Breaks, Replaces for every possible conflicting package in Debian. As we will be shipping our Bluetooth implementation in future, it will be recommended and we suspect people will not install the upstream package.