Kodi 17.1 does not boot anymore

Your SD card has probably failed. I’d suggest a new SD card and fresh install.

I have read a lot of comments that OSMC will not complete the boot process on RPi 2 B+. Most of the responses seem pretty defensive. Trust me, there is a problem! I run the current Raspbian, on a Pi 2 B+ with an upgraded power supply, without issue but it will not load KODI 7.1. I have also built two SD cards; one 32GB with the latest build and one 16GB with the previous build. All three perform identically; they boot (or appear to load), they install, there is a three line command, the blue OSMC screen appears for 30 seconds and the screen goes blank. I see the processor working for about 5 min. Then nothing… black screen, nothing.

Perhaps I am asking too much of a Pi 2 B+ to run KODI? I run KODI on my Android phone. I run KODI in Windows 10 on my 10 year old Dell desktop development system. I run KODI in Ubuntu 17.10 on my 10 year old Dell laptop. Should I just give up on the Pi?

Hi ex-ibm,

Sorry to you are having issues, please provide logs:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

The best way if you getting a blank screen, is to issue:

grab-logs -A

From the commandline and provide the pastebin link and we will help to resolve this issue. There are still many users running osmc on pi2.

Thanks Tom.

1 Like

Then this is not an OSMC issue and you should be addressing your problem with Kodi developers. Good luck.

Gee… OSMC will not load KODI in its boot process. KODI will not load in Raspbian. Must be a KODI problem. What do you recommend that actually works with OSMC?

Hi ex-ibm,

I would recommend trying osmc on another sd card and providing logs, so we can diagnose further.

Thanks Tom.

Your issue is an outlying exception. There are tens of thousands of OSMC users without this issue. Unfortunately, you’ve provided exactly zero diagnostic information that could be used to solve your problem. Even your statement that you use an “RPi 2 B+” is erroneous as such a thing does not exist.

1 Like

My apologies to the team… 100% cockpit error. It is a bit quirky, however. I changed from overclocking at 1000 to 900; no difference. Then in a pure mistake I hit the HDMI button on the TV remote and selected HDMI1. OOPS, when I went back to HDMI2 where I run the Pi, presto, there was KODI. So, armed with new information, I rebooted OSMC. As soon as the screen went black I did the HDMI2->HDMI1->HDMI2 and there it was. Interesting issue. Is it the OS or is it KODI, I have no idea. The same thing happens with Raspbian when I launch KODI. If I swap HDMI channels its there. Its either something in the OS or my TV (VISIO 23" smart TV - well not so smart afterall!). I hope someone can benefit from my stumbling on to this issue.

Overclocking can give you problems. There isn’t much to really be gained from it.

The first way to diagnose an issue is always to back off from any overclock.

That sounds like a handshake issue to me.
hdmi_force_hotplug=1 will likely fix that.

Sam