Kodi 18 - Suspend not working

Hi all!

Since the topic “V18 - Suspend not working” is marked as solved, I open a new topic.
With Kodi 18 my Vero 4K+ wasn´t able to suspend anymore so I followed post #32 (see “V18 - Suspend not working”) and updated my Vero.

Now after the update I´m finally able to suspend the device and the red LED turns on but after couple of minutes the LED turns off. If I turn the TV on I immediately see the Kodi home screen.

I´m using the default OSMC skin without any special addons.

I have only the standard remote and during my tests didn´t run the iOS Kodi Remote.

HDMI CEC isn´t active.

I created the log files:

after the restart I suspended the Vero. After powerup I created the logs (I deleted lines with information about my movies/series)



The fix hasn’t been released as a stable update yet. Did you update to the staging repository?
It is scheduled for release on Sunday.

1 Like

Hi Sam!

I know, I used the stretch-devel main repo as you suggested in the other topic.
And it solved the problem partially, because before the update suspend was 80% unsuccessful: after hitting suspend the Vero came back immediately.
With the devel update suspend works always, but after 5-10 Minutes Vero comes back.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Thanks for clarifying that there’s a slightly different issue at hand.

The ‘Skin Helper’ add-on seems to be waking up the device.
I’m not sure why.

To bypass this issue I was using the shutdown option in kodi and switching on by removing and replacing the power plug.

The interesting thing I noticed was that by doing that, my Vero was able to turn on the AVR and the TV, unlike the suspend mode.

Is there anything that can be done to make it work on the suspend mode ?

Suspend will work in the next update; but there may be a case of some add-ons still waking the device up.

Hi Sam!

the May-Update didn´t solve the problem so I reinstalled the Vero and configured only basic things (OSMC home screen, fstab). Right now everything is perfect, suspend works.

I think the Skin Helper´s “In progress movies” widget caused previously the problem.
Do you know a different way to create an “in progress” movie widget which doesn´t wake up the device?


I don’t know much about Skin Helper
Maybe I can stop some addons from waking the device


Skin helper isn´t important to me I just want an “in progress” solution with the OSMC skin.

Actually I prefer the built-in solutions over some “third party products”… :blush: