[Kodi 19] HDMI extractor's audio stopped working

After the update to Kodi 19 on my Vero 4K+, optical audio output on my HDMI extractor stopped working. Could you help me understand how I can fix this issue?

Here’s my setup:

  • Vero 4k+ connected over HDMI to StarTech HDMI Audio Extractor
  • HDMI Extractor connected over HDMI to a beamer
  • HDMI Extractor connected over an optical cable (Toslink) to a soundbar (Samsung HW-A450)

With Kodi 18 every worked fine. Exactly after the update to Kodi 19, I get no audio over the optical cable.

I’ve tried the following:

  • Connecting the optical cable directly to Vero 4k+, audio works (i.e., the optical cable works)
  • Connecting the HDMI Extractor to Switch, audio works (i.e., the extractor still works).
  • Switching to different extractors: Delock HDMI Audio Extractor and Lindy Audio Extractor. Both suffered from the same issue (i.e., it shouldn’t be some special extractor incompatibility).
  • Turning the audio on the beamer, it works, so the HDMI does emit audio information.

I’ve generated logs at https://paste.osmc.tv/raw/mikeronabo. In the logs:

  1. I start with the cable attached to the HDMI extractor
  2. play “A.Redacted.Movie” (gives no audio)
  3. pause
  4. Attach the optical cable directly to Vero 4k+
  5. resume (gives audio)

I’ve searched the forum for whether this problem has already been reported. I’ve found Passthrough not working in 19.1? (solved) - #16 by JimKnopf but the advice didn’t work for me (I had stereo upmix off BTW).

There’s no kodi.log in what you posted.

I thought I followed the advice recommended at How to submit a useful support request. I’ve linked to what I thought was the recommended log (https://paste.osmc.tv/raw/mikeronabo .)

What is kodi.log and how can I get it?

my bad - incomplete download.

You have your channels set to 2.1. You will need to set that to 2.0 and enable Dolby Digital Transcoding.

Believing the manual this device supports “Supported play formats (DTS 2.0 sound is played in DTS format.) … LPCM 2ch, Dolby Audio™ (supporting Dolby® Digital), DTS”, only.

Only the Startech Audio extractor HD202A offers an SPDIF port and supports “SPDIF: PCM 2.0, Dolby Digital und DTS 5.1” by that.

Obviously several things should be corrected in your settings including @grahamh’s suggestion:

  • settings → player → adjust display refresh rate to always or start/stop (this should be set in any case!)
  • settings → system → audio → output device to AML-MESONAUDO, HDMI
  • settings → system → audio → number of channels to 2.0
  • settings → system → audio → enable Dolby Digital (AC3) transcoding to TRUE
  • settings → system → audio → Dolby Digital Plus (E-AC3) Receiver to FALSE
  • settings → system → audio → TrueHD capable receiver to FALSE
  • settings → system → audio → DTS-HD capable receiver to FALSE

This solved my issue. In hindsight, I should have checked the audio tech compatibility of my devices. Thank you for your patience.

1 Like

Unfortunately I’d like to reopen the issue. Audio extraction doesn’t work for all movies. It happened to work on the one movie that I tested it on.

In https://paste.osmc.tv/guhazururu I play WeWork.or.The.Making.and.Breaking.of.a.47.Billion.Unicorn.2021.720p.WEBRip.800MB.x264-GalaxyRG.mkv and the audio doesn’t work. I have uploaded the movies Mediainfo file to https://paste.osmc.tv/raw/inabegitik. You can find the Mediainfo of the file in the OP at https://paste.osmc.tv/raw/ubinomapal.

I’m at a loss for how to use this data to understand what might go wrong with Kodi or what would I need to do to debug. Could you help?

We have had a look into the provided logs but do not see any issue, there. At timestamp “20:36:25” the Vero started to send 2 channel PCM 48kHz via hdmi since the Vero finds 2 channel audio AAC LC in the video source … all as configured and as expected.

The only thing I found is that your soundbar got a new firmware at end of June 2021 but there is no information what changed: 2.1-Kanal Soundbar HW-A450 | Samsung Support Schweiz.

Just to be sure: You connected the Vero to the splitter using the hdmi IN port, the beamer to the hdmi OUT port … and already tried every of the three EDID modes? https://sgcdn.startech.com/005329/media/sets/hd202a/hd202a_qsg.pdf

Also you have tried settings:

  • settings → system → audio → keep audio device active to ALWAYS
  • settings → system → audio → send low volume noise to TRUE

Last question: Why you have to use this hdmi splitter at all? The output device is a beamer and the only function for this splitter is to provide an audio signal using S/PDIF … which you can get directly from the Vero itself. You mention in your opening post a “switch” … but it is not clear what you mean by that?

The two videos you tried have AAC audio. This is not a passthrough format so by default it’s decoded to PCM. But if multi-channel, it’s re-encoded to AC-3 (Dolby). The first video is ‘5.1’, although actually only 3 channels are used:
CAESinkALSA::Initialize - Requested layout: FL, FR, LFE

That was Vero trying to send 3 channel PCM, which failed since S/PDIF is only two channels for PCM. The second video is 2.0 so is being sent as PCM.

2021-08-17 20:36:25.654 T:2669    DEBUG <general>: CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2
2021-08-17 20:36:25.654 T:2669    DEBUG <general>: CAESinkALSA::GetChannelLayout - Requested Layout: FL, FR
2021-08-17 20:36:25.654 T:2669    DEBUG <general>: CAESinkALSA::GetChannelLayout - Got Layout: FL, FR (ALSA: none) (CEA: 0)
2021-08-17 20:36:25.654 T:2669    DEBUG <general>: CActiveAESink::OpenSink - ALSA Initialized:
2021-08-17 20:36:25.654 T:2669    DEBUG <general>:   Output Device : AML-MESONAUDIO
2021-08-17 20:36:25.654 T:2669    DEBUG <general>:   Sample Rate   : 48000
2021-08-17 20:36:25.654 T:2669    DEBUG <general>:   Sample Format : AE_FMT_S24NE4
2021-08-17 20:36:25.654 T:2669    DEBUG <general>:   Channel Count : 2
2021-08-17 20:36:25.654 T:2669    DEBUG <general>:   Channel Layout: FL, FR

I’ve tested your configuration with one of these:

Everything works as expected - I’m getting 2.0 PCM from AAC 2.0 with the settings @JimKnopf recommended. Note that the position of the EDID switch doesn’t matter as Vero doesn’t check the audio capabilities of the display/AVR.

What happens if you play a video with stereo PCM with passthrough turned off on Vero?

2 Likes

I’ve turned settings → system → audio → stereoupmix to YES (contrary to Passthrough not working in 19.1? (solved) - #14 by Paul_Solecki) and now both movies work. My problems seem to be resolved.

The audio for both movies is off.

Yes, they didn’t help.

Yes, I’ve rechecked the connection and have tried all EDID modes. They didn’t work.

The “switch” in question is Nintendo Switch. I use a HDMI to splitter to channel audio from both devices using one audio cable (my speaker is far away from Vero and Switch). I can draw a diagram to explain if needed.

Yes, please. Still not seeing why this splitter is need.

Video Setup

I think you mean “HDMI switch” instead “HDMI splitter”, right?

What brand/model?

Did you ever tried to direct connect the Vero to the HDMI audio extractor? (not sure about this reading your first post)

Yes.

I’ve tried Link2Go HDMI Switch-Kabel and Delock 2 Port HDMI Switch. I’m currently using the former.

Yes. I didn’t mention the switch in my original post, because my intention was to create a minimal reproducible environment, i.e., I didn’t use the switch.