Kodi accessing folder on LAN


I’m setting up a debian home-server which stores a media folder, which Vero will access via the LAN.
I’ve read that NFS is the preferred option.

Though bit confused if I have to first set up both home-server (as server) and vero osmc (as client) as indicated with these instructions. And then within Kodi, access the folder?
Or is there a different way of doing this?

Additionally, I’d need to mount the shared folder on osmc via fstab and to make it persistent after a reboot?


I recommend you use autofs rather than fstab. What I do is mount all remote shares in /mnt/ on OSMC and then in Kodi add those sources through the ‘root file system’ option.

See File sharing with a NAS, media server, windows share or other device and Mounting network shares with autofs (alternative to fstab)

The instructions you linked are a bit dated. The modern way to manage nfs-server is via systemd:

sudo systemctl enable nfs-server
sudo systemctl daemon-reload
sudo systemctl start nfs-server

Thanks. I followed your links and tried to set up autofs, though can’t get it to work.

My LAN only debian server has static ip: which I set up nfs server to share folder ‘/data/mov’

One OSMC Edited auto.nfs.shares:

Output of:

showmount -e

    Export list for
    /data/mov (everyone)

(I can mount this folder on my linux pc).

Though on OSMC when I try:
ls -lah /mnt/
ls: cannot access '/mnt/': No such file or directory

Not sure if this is right format for the path

Any advice will be appreciated

If the server will run 24/7, my personal preference is for fstab. IMO, autofs is more useful when the server might not always be accessible, since it reduces the possibility of system hangs.

As to your problem, you say:

but then look for /mnt/ Have you tried looking in /mnt/mov?

As @dillthedog it seems you were looking in the wrong folder. Check /mnt/mov

But also you only wrote abut edited auto.nfs.shares.
Did you also added /- /etc/auto.nfs.shares --timeout 15 browse to /etc/auto.master?

After also reading this guide, I realised I didn’t understand what was going on, and editing folders incorrectly.

Have it working now.

Thanks for your help.