Kodi and Home Assistant


I have installed the latest OSMC (2019.10-1) on my RPI 3 to use Kodi. I integrated Kodi in my Home Assistant, but the state of the Kodi media player is always off. I searched and found in this thread that I need to enable the web interface in Kodi. It was already enabled, but the option “Allow remote control from applications on other systems” is off and cannot be enabled. If I enable it, I get the error “failed to start” and usually Kodi crashes afterwards. Here the log:


system logs:

2019-11-22 14:27:50.498 T:1600123616 DEBUG: PushCecKeypress - received key b duration 0 (rep:0 size:0)
2019-11-22 14:27:50.498 T:1600123616 DEBUG: PushCecKeypress - added key b
2019-11-22 14:27:50.510 T:1916171824 DEBUG: HandleKey: 11 (0x0b, obc244) pressed, action is Select
2019-11-22 14:27:50.511 T:1916171824 NOTICE: ES: Stopping event server with confirmation
2019-11-22 14:27:50.579 T:1629209312 NOTICE: ES: UDP Event server stopped
2019-11-22 14:27:50.579 T:1629209312 DEBUG: Thread EventServer 1629209312 terminating
2019-11-22 14:27:50.579 T:1757471456 DEBUG: Thread EventServer start, auto delete: false
2019-11-22 14:27:50.579 T:1757471456 NOTICE: ES: Starting UDP Event server on port 9777
2019-11-22 14:27:50.599 T:1620693728 DEBUG: Thread TCPServer 1620693728 terminating
2019-11-22 14:27:50.600 T:1916171824 DEBUG: JSONRPC Server: Failed to bind IPv4 serversocket
2019-11-22 14:27:50.600 T:1916171824 DEBUG: JSONRPC Server: Failed to bind IPv6 serversocket
2019-11-22 14:27:50.600 T:1916171824 ERROR: JSONRPC Server: Failed to create serversocket(s)
2019-11-22 14:27:50.600 T:1916171824 DEBUG: ------ Window Init (DialogConfirm.xml) ------
2019-11-22 14:27:50.600 T:1916171824 INFO: Loading skin file: DialogConfirm.xml, load type: KEEP_IN_MEMORY
2019-11-22 14:27:50.619 T:1600123616 DEBUG: PushCecKeypress - received key b duration 123 (rep:0 size:0)
2019-11-22 14:27:50.619 T:1600123616 DEBUG: PushCecKeypress - ignored key b
2019-11-22 14:27:50.840 T:1496306400 DEBUG: CWebServer[80]: request received for /jsonrpc?JSONRPC.Ping
2019-11-22 14:27:50.872 T:1550832352 DEBUG: Previous line repeats 4 times.
2019-11-22 14:27:50.872 T:1550832352 DEBUG: CWebServer[80]: request received for /jsonrpc?Application.GetProperties
2019-11-22 14:27:50.897 T:1689854688 DEBUG: Previous line repeats 4 times.
2019-11-22 14:27:50.898 T:1689854688 DEBUG: CWebServer[80]: request received for /jsonrpc?Player.GetActivePlayers
2019-11-22 14:27:51.779 T:1504699104 DEBUG: Previous line repeats 4 times.
2019-11-22 14:27:51.779 T:1504699104 DEBUG: CWebServer[80]: request received for /jsonrpc?JSONRPC.Ping
2019-11-22 14:27:51.801 T:1504699104 DEBUG: CWebServer[80]: request received for /jsonrpc?Application.GetProperties

Not sure whether this is a Kodi or OSMC issue, so I’m posting it to both forums.

Provide full logs (including system logs) to enable us to support you

I have added the full log. Where do I find the system logs? There is no useful log under /var/log/

Use either the log uploader under MyOSMC or on the command line grab-logs -A

1 Like

system logs:

I’m unable to reproduce the problem. You can always shut down Kodi and then manually edit /home/osmc/.kodi/userdata/guisettings.xml manually. When enabled, the line should read:

 <setting id="services.esallinterfaces">true</setting>

You also have the Kodi Web interface on port 8080, rather than 80.

I did that and now OSMC/Kodi won’t boot up -.- It starts booting and then just turns off, no message, no nothing.

Edit: I installed it using PINN. PINN boots up fine, and when it want’s to boot OSMC it just shuts down

Just to be clear, only Kodi is failing and the Debian operating system is still working, right?

Assuming that the answer is yes, you can see if Kodi starts with a default configuration. Via SSH:

systemctl stop mediacenter
mv .kodi kodi.bak
systemctl start mediacenter

If it starts ok, you might have a corrupted config file or a setting (or settings) that Kodi doesn’t like.

No, Debian is failing. I cannot access it via SSH either. Can I put the SD card into my laptop and access the guisettings.xml from there? Then I can revert the changes. I assume it has to do with that.

Only if your laptop can write to a ext4 partition (so basically anything Linux, but not Windows or Mac without extra configuration or software).

Well, you can try to revert the setting but the failure of Debian points to a more fundamental problem, such as a major filesystem corruption, possibly caused by a failing SD card, or something related to PINN.

Perhaps @sam_nazarko can also tell us if PINN is supported.

I’m running Ubuntu, so I’m good to go. I’ll try in a bit when I’m home.

I doubt it’s the SD card, it literally happened when I changed the option in the xml file. Would be super random of the SD card broke right then.

Edit: I accessed the xml file and it reverted back to “false” automatically. I’m not too sure what the issue is and why it’s crashing. I’m trying to use PINN now to get a debug log.

Edit2: I’m not even sure if this has anything to do with Kodi/OSMC atm. I went into PINN’s boot menu and booted RetroPie (my 2nd OS) and that’s not booting to. At least I’m not seeing anything on my screen and there’s no active connection lised in my router. BUT the SD Card activity LED is blinking… It’s very confusing.

Edit3: this is where I am at so far: I went into PINN, ran a file system check and there was one corrupt bit on both OSes and PINN OS. I fixed all, but it still won’t boot into any OS. Also, when I do “ctrl + alt + F2” it prompts me with a login for the shell. There, it also just goes to a blank screen (TV is loosing the connection to the RPI). Once I managed to enter RetroPie, but it was random. No other try was successful. I assume that the SD card is corrupted. Could I make a 1:1 image and just put it onto a new SD or will the error remain?

If you have an SD card that has issues and you image it how would you know that what you previously identified was the only corrupted information? You could get it to a working state and then keep on running into odd things that drive you nuts trying to track down what is going on. If it was me, and I really didn’t want to start my Kodi library from scratch I would just copy over the userdata folder, minus the thumbnails folder and guisettings.xml, load that into a fresh install, export out nfo files, dump that userdata folder and let it make a new one, then put in import watched state in advancedsettings.xml and import into a new fresh library.

1 Like

Okay I will do so then. I ordered a bunch of new SD Cards anyway. Does the userdata folder also contain all the addons and additional repositories I installed?

I think the add-on’s themselves are stored in the .kodi/addons/ folder and the user settings for them are stored in .kodi/userdata/addon_data/. The repositories I think (don’t quote me on this) I think are stored in the .kodi/userdata/sources.xml file. You can of course just open the file and look for yourself. The sources.xml and passwords.xml (if you have one) should be fine to keep on the new install as well as you can open them and see if they are corrupted. The reason why I suggested to dump guisettings.xml is because it would be a lot more difficult to visually inspect that one due to its size and Kodi normally falls on its face if there is any errors in it.

1 Like

Okay thank you! I will try it all and report back!

The sources.xml is quite unspectacular: https://paste.osmc.tv/ebarofokov.xml

In your case it is, as it would seem that you were probably just running a single hard drive that was directly connected to our RPi. As far as the repo’s go they are often put in by first making a new file path with the ‘file manager’ in settings and that path is used to install the actual repository using the ‘from zip’ option in the add-ons section. The “files” section of the sources.xml is where the added ‘file manager’ paths are stored but the actual repos themselves are stored the same place as the add-ons (they are named repository.[something]).

Okay, so I got Kodi up and running again. Everything seems to still be there (addons, settings, etc.).

I’d like to go back to the actual issue now. I still cannot activate that setting (“Allow remote control from applications on other systems”). I’m not sure if that’s even relevant for Home Assistant since I can access the Kodi WebGUI from my laptop. Do you have any idea why it still shows Kodi as off in Home Assistant even though Kodi is running?

Edit: the esalinterfaces thingy keeps being set to false after every boot of kodi. Not sure why it doesn’t wanna activate that setting

Edit2: I used the advancedsettings.xml to change the settings. It’s still not working within Home Assistant: hastebin