Kodi as renderer for UPnP control point


Running Kodi 14.1 on my Raspberry Pi 2. I have trouble setting up Kodi as the renderer in BubbleUPnP on my phone.
UPnP is enabled in Kodi.

I am taking the following steps:

  • Restart the Pi;
  • Check BubbleUPnP: Kodi is available as renderer; Selecting
  • Kill BubbleUPnP, wait approximately 5 minutes
  • Start BubbleUPnP again, now the app will try to use the Kodi renderer, but fails, reverts to local, and Kodi is no longer in the options list

The only way to make it reappear is by restarting the Pi.
Apps similar to BubbleUPnP exhibit the same behaviour.
Is there a configuration setting in OSMC / Kodi that I am missing?

Thanks in advance!

Hi Im using Bubbleupnp with osmc and it´s working great. All i´ve done is to enable all four entries under the UPNP setup in osmc. After that kodi shows up in Bubbleupnp.

Thank you.

That is exactly what I have done. And as stated, initially it is working. That is, until the next session.

Have you tried the tweaks in Bubblepnp? The ones i´ve enabled are “Gapless control”,“Mine-type check” “Use eventing” and “server side search”. There´s also a “Blast alive messages” setting there might be worth a shot.

I use Bubbleupnp with osmc for several hours (for internet radio and music stored on the phone) on a daily basis, with the raspberry pi 2 so it should also be possible for you. Hope you figure out whats wrong. Good luck

Thank you Skov for your help. My settings mirror yours at the moment. Unfortunately this does not solve the problem.

I have also tried this with an Xbian image and the results are the same. Reboot, find Kodi, Try to reconnect after 3 - 5 minutes, to find that it’s gone. Must be something in my network then.

I have the same problem. But reboot not needed. Only on/off Settings -> Services -> UPnP/DLNA -> Allow remote control via UPnP for response Kodi in BubbleUPNP. [Expert mode settings in Kodi].

If you are using wifi, is “wait for network” ticked ?

I had all sorts of issues with upnp until I did that

Hi guys, i am a proud owner of vero 4k and what bothers me is exactly this problem.

I have enabled all checkboxes under upnp settings in kodi, but in bubble i can’t choose kodi as reenderer.

Are there any options available?


Well did you also activated “wait for network” which was tipped by @penfold42 above.

Also not 100% sure what you exactly want to do with Bubble, most can be done with Yatse or Kore

Huh, don’t know what happened. Its working now. I have enabled upnp kodi client on Windows machine. Since then its working… Huh :rofl::wink:

Not for long. I was trying one more time and again there is no kodi among reenderers. It has to be something in conflict with Windows machine?

I am using lan, no wifi :wink:

So here is the deal. Everytime i run bubble upnp i must disable and then reenable setting Allow remote control via Upnp.

After this i can choose vero 4k immediately.

Any idea?

I think i find a solution for this. In osmc i enabled tvheadend service, now it looks like this could work :wink::wink: