Kodi.bin at 100% - CPU very hot


Last 2 weeks i am expiriencing wierd problem. When i start watching video over NFS share (not every time but most of times) i get temperature warning in top right corner and my RPI3 start to struggle with playing video. After examination on my phone i can see that process kodi.bin is at 100% for at least 10 or 15minutes and my cpu is at 80 degrees celsius. After 10 or 15 minutes everything goes back to normal and I can’t find a reason why it does that. Here is my log if someone can see it and find my problem: https://paste.osmc.tv/taconulesa

In my log i can give you an example when it happens. You can search a line with:
2020-11-22 17:01:13.303 T:1208090848 (that was yesterday when i started to watch a video and it happens)

Thank you for your help and answers.

  1. If you want to figure out what is going on you would need to enable debug logging
  2. 100% Kodi CPU very often is linked to rogues addons, so you may want to review your addons

I have disabled every addons i have (i left only Youtube).

I will enable debug logging and check there, if i will not findy anything i will post it here.

So the log i uploaded is useles?

Well after the movie starts at 17:01 there are no further entries for a long time. So yes do find the issue they are useless.

80°C on a Raspberry Pi is an acceptable I believe.

I noticed thermomether icon and my RPI3 didnt like that because it was shuttering and struggeling to play. When it was over everything was fine.

I tried to debug log but this time it didnt have problems.

You could try turning this back on…

<setting id="videoplayer.usemmal">false</setting>

but if your seeing the temperature icon one normally would be looking at their hardware. Do you have a closed case or a heatsink that might have become more insulative than conductive? Is it located on a hot location or in proximity to a heat generating device?

I have my RPI3 in closed case (official Raspberry case) and i have heatsink which i bought on OSMC website 2 months ago. My RPI3 It is away from any heat source.

Why do you suggest me to use MMAL. I use OMXPlayer because i get much smoother playback than MMAL. Because when i use MMAL i have to use Sync playback to display to get smooth video but then sometimes i have bizzare sound issues when my audio become like an old proclaimed orchestra.

Do you think i have issues because of OMXPlayer?

Pop the lid off and see if the issue goes away. Might also check to make sure the heatsink if firmly stuck down. I’ve not touched the OSMC product but generally speaking it is possible for thermal adhesives to become loose at which point they end up trapping heat instead of conducting it. If you can give it a nudge and it seems stuck then your probably good there.

Regarding MMAL try it and find out. I don’t notice any difference in playback smoothness with that on or off. I don’t remember reading anyone else with that issue either. Sync playback to display should never be used with a regular TV, only adjust refresh rate. I don’t use OMXPlayer and it is not enabled by default. That being said I do turn it on from time to time for testing and don’t find playback any different than video player (outside of bugs with some add-ons like Plex).

Heatsink is firmly attached. I tried to take the lid off an even tak the PI out of case but problem stil exist.

Right now i tried to use MMAL without sync playback to display and it works fine (wow).

I was using adjust refresh rate (on start and stop). I am annoyed because it changes refresh rate everytime i start a video. Is it ok to use without adjust refresh rate because i dont see any difference in playback with enabled or disabled.

That will not damage anything but it will force all video to resynced to the refresh rate set in the UI. This will affect playback differently depending on the source. If you have your UI set to 50hz and are playing back 25 or 50fps content they everything is golden. If you then play a movie that is 23.976 fps then likely you will see uneven playback as it will have to add and throw away frames that should not be there in order to output to 50hz. There is a middle ground if the blank screen during playback starts really bothers you and that is setting refresh rate switching to “on start”. This effectively makes your UI refresh rate whatever the last video you played was. This way the screen only switches when the frame rate changes so if you go from one episode to another in the same program you don’t get switches. The downside to this is that animations in the UI and perhaps the UI itself can seem a bit sluggish when it is in the lower refresh rates. This is likely personal if it would even be noticed.

Thank you for your informative answer. I am very happy about OSMC comunity because you guys are really helpfull.