Kodi Can't see NFS Share

Hi
Today I rebuilt my OSMC server on a RPi3 on a brand new SD card. I copied out the .kodi and .hts files from the old card and after installation I copied them back to the new card.
I am having a problem with NFS from existing Kodi clients that already had the disks PiDisk1 and PiDisk2 set up they can see and play files.
If I remove one of the disks from Kodi and then try and add it back Kodi can’t see the nfs server

Here are the logs https://paste.osmc.tv/debipuliso

Please can someone tell me what has gone wrong

Thank you very much

Keith

Well, the obvious question is why are you doing that in the first place? If, after you start the server, you don’t remove / add back the disk can the other clients see the NFS share?

Hi @dillthedog
I was trying to set up my tablet to access the disks and it couldn’t see either of them so on my PC I removed one to see if I could add it back. It couldn’t see it either from the PC and if I manually added the URL when I click on it to display the files it says it cannot connect to the server. Before I removed the disk it could see the files

People have similar issues if a server powers off for a while. It’s just a bad idea to pull a disk like that when clients are accessing the share.

I think the main issue is why the tablet couldn’t see the shares in the first place. Were they visible from the tablet before the rebuild?

It is a new tablet and I was setting it up. I just tried my phone and it had one of the disks already defined and it will play a recorded TV programme. Like my PC which will also play files if I go to the screen to add a share when I click on the NFS line to add a share it locks up for a bit and then it unlocks and nothing has happened. So none of my devices can see the disks but if they were added before I rebuilt the server they are able to play files

Over the weekend I rebuilt my OSMC server on a Pi4. It is a completely up to date new build. I have 2 powered external harddrives one for recording TV programmes and the other for holding ISO files of all our DVDs. I have followed the instructions for updating FSTAB, and the exports file and the exportfs -e command all of which seem to work OK.
From any client now clicking on the Network File System (NFS) line in Kodi to add the drives nothing happens for a bit and then nfs:// appears at the bottom of the screen and that is it.
The same happens if I try the same thing from the server itself.
I used the same IP address as I had before and again as in my previous attempt above clients that already had the shares set up are able to see and play the files on these 2 disks but if I try to see what NFS shares are available I just get nfs://
In the log I get
2021-08-22 16:12:42.247 T:1083 ERROR : GetDirectory - Error getting nfs://
2021-08-22 16:12:42.247 T:1083 ERROR : CGUIDialogFileBrowser::GetDirectory(nfs://) failed
Can anyone help please

What is the output of `showmount -e giving you run on any of the clients

@fzinken on the server itself I get

osmc@osmc-server:~$ showmount -e
Export list for osmc-server:
/mnt/PiDisk2 192.168.1.0/24
/mnt/PiDisk1 192.168.1.0/24
osmc@osmc-server:~$

On another Pi I get
osmc@osmc-Lounge:~$ showmount -e
Export list for osmc-Lounge:
osmc@osmc-Lounge:~$

The other clients are Windows or Android so I don’t know how to run the command

You should run showmount -e <IP of OSMC Server>

@fzinken I am getting

osmc@osmc-Lounge:~$ showmount -e 192.168.1.28
Export list for 192.168.1.28:
/mnt/PiDisk2 192.168.1.0/24
/mnt/PiDisk1 192.168.1.0/24
osmc@osmc-Lounge:~$

So it can see it so why can’t Kodi

At this point, I think the best way forward is for you to provide full logs – grab-logs -A – and post the URL it returns.

Hi

This is from one of the PI clients. I rebooted it and then attempted to display the NFS shares.

https://paste.osmc.tv/womesofanu

Besides the network issues, I see in the last logs nearly 500 error messages like

Aug 24 18:10:47 osmc-Lounge kernel: usb 1-1-port2: over-current change #1

If you’re using the right power supply for this pi3 B, this could point to a HW issue … but I’m not very familiar with the Raspberries.

I suggest that you try to mount the share(s) from the command line and see what happens:

sudo mkdir /mnt/pd1
sudo mount -v -t nfs 192.168.1.28:/mnt/PiDisk1 /mnt/pd1
mount

If the mount appears to have worked:

ls -la /mnt/pd1

You could also try ls -la /mnt/pd1/TV to see if there are any permission issues, though it’s probably not worth posting the full output

@JimKnopf Thank you very much. I will look into it

@dillthedog I can mount the drive and I can see the top folders

osmc@osmc-Lounge:~$ ls -la /mnt/pd1
total 124
drwxrwxrwx 13 osmc root   4096 Jul  8 15:41  .
drwxr-xr-x  3 root root   4096 Aug 24 22:36  ..
drwxrwxrwx  2 osmc video 20480 Aug 24 15:15  Dramas
-rwxrwxrwx  1 osmc osmc    550 Jan  3  2021 'Failed Recordings.txt'
drwxrwxrwx  8 osmc osmc   4096 Dec 16  2020 'Film and TV'
drwxrwxrwx  4 osmc osmc  20480 Aug  1 00:47  Films
drwxrwxrwx  3 osmc osmc  12288 Aug 22 00:12 "Keith's Films"
drwxrwxrwx 13 osmc osmc   4096 Aug 17 15:15 "Keith's TV"
drwxrwxrwx  2 osmc osmc   4096 May  2 17:37 "Lesley's Films"
drwxrwxrwx  6 osmc osmc  12288 Aug 24 16:00 "Lesley's TV"
drwxrwxrwx 10 osmc osmc   4096 Dec 31  2020 'Music Videos'
drwx------  3 osmc osmc   4096 Jul 29 18:09  SharedData
drwxrwxrwx 92 osmc osmc   4096 Aug 21 22:00  TV
-rwxrwxrwx  1 osmc osmc    246 Jan  7  2017  WriteProgInfo
drwx------  2 root root  16384 Jan 24  2021  lost+found
-rwxrwxrwx  1 osmc osmc     63 Mar 23 11:16 'to be deleted.txt'

and I can see the contents of the TV folder

osmc@osmc-Lounge:~$ ls -la /mnt/pd1/TV
total 5143620
drwxrwxrwx 92 osmc osmc        4096 Aug 21 22:00  .
drwxrwxrwx 13 osmc root        4096 Jul  8 15:41  ..
drwxrwxrwx  2 osmc video       4096 Mar  3  2018 'A Little Chaos'
drwxrwxrwx  2 osmc video       4096 Aug 21 22:00 'A White, White Day'
drwxrwxrwx  2 osmc video       4096 Dec 31  2020 "Andre Rieu_ New Year's Eve"
drwxrwxrwx  2 osmc video       4096 Dec 31  2020 "Andre Rieu_ New Year's Eve Punch"
drwxrwxrwx  2 osmc video       4096 Aug 22 22:00  Baptiste
drwxrwxrwx  2 osmc video       4096 Jul 17 22:00 'Beck_ Death in Samarra'
drwxrwxrwx  2 osmc video       4096 Jan  6  2017 'Big Fat Quiz of Everything'

Just found this article
NFS - Official Kodi Wiki view/NFS#NFS_sharing_from_Linux
Section 3 deals with sharing NFS from linux and it mentions that a later version of NFS stops the search from Kodi working and you have to give it the address of the server in a mediasources.xml file under userdata.
When I added the mediasources.xml file with the address of the server I can now see the NFS shares.
I will have to put it on all my clients.

Thank you to everyone for looking at this

2 Likes