KODI crash loop after update

Hey everyone :slight_smile:
Please excuse the noob question but after the last update I installed I am stuck in an endless sad face loop… Don’t really know what to do. So I logged into the Pi with SSH and dumped these logs:

root@Sin:/home/osmc# paste-log /var/log/apt/history.log
root@Sin:/home/osmc# paste-log /var/log/apt/term.log
root@Sin:/home/osmc# paste-log /home/osmc/.kodi/temp/kodi.log

I see there are a few errors in the Kodi Log → however I have no idea on how to tackle them.
Any ideas? Need any other logs?

You shouldn’t be running apt-get upgrade, always apt-get dist-upgrade

1 Like

If you ran apt-get upgrade you will have problems. You should always use apt-get dist-upgrade

Doing the following will probably resolve the issue:

sudo apt-get update
sudo apt-get -f dist-upgrade

If the problem persists after the above, grab-logs -A will paste all useful logs in one go.

Thanks for the replies guys.

Unfortunately it didn’t work, I’m still in a sad face loop…

here’s the log dump


Are you sure you ran apt-get -f dist-upgrade as I suggested ? There is no evidence of this in the log file you just provided…

This is still the last history.log enty:

Start-Date: 2016-04-14  19:29:02
Commandline: apt-get upgrade
Upgrade: python-ldb:armhf (1.1.17-2+deb8u1, 1.1.20-0+deb8u1), libldb1:armhf (1.1.17-2+deb8u1, 1.1.20-0+deb8u1), libtdb1:armhf (1.3.1-1, 1.3.6-0+deb8u1), samba:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), samba-common-bin:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), python-talloc:armhf (2.1.1-2, 2.1.2-0+deb8u1), libtalloc2:armhf (2.1.1-2, 2.1.2-0+deb8u1), samba-common:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), libtevent0:armhf (0.9.21-1, 0.9.25-0+deb8u1), python-samba:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), tdb-tools:armhf (1.3.1-1, 1.3.6-0+deb8u1), python-tdb:armhf (1.3.1-1, 1.3.6-0+deb8u1), samba-dsdb-modules:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), libsmbclient:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), samba-libs:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2), base-files-osmc:armhf (1.9.0, 1.9.1), libwbclient0:armhf (4.1.17+dfsg-2+deb8u2, 4.2.10+dfsg-0+deb8u2)
End-Date: 2016-04-14  19:33:12

Same here after updating with the built-in updater. :disappointed:

Don’t threadjack.

You’ve already posted twice. If you want the issue solved, start a new post.


Please tell me where you read this advice so I can ask if they can amend their instructions


Thank you all :slight_smile:

you’re right… so I did it again →


but it still doesn’t show up in the logs… so I’ll just paste my console:

root@Sin:/home/osmc# sudo apt-get update
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates InRelease
Hit http://apt.osmc.tv jessie InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://ftp.debian.org jessie Release
Get:1 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [1996 B]
Hit http://ftp.debian.org jessie-updates/contrib armhf Packages
Get:2 http://ftp.debian.org jessie-updates/non-free armhf Packages/DiffIndex [736 B]
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Get:3 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [1228 B]
Get:4 http://ftp.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/contrib armhf Packages
Hit http://security.debian.org jessie/updates/non-free armhf Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://security.debian.org jessie/updates/non-free Translation-en
Get:5 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B]
Hit http://ftp.debian.org jessie/main armhf Packages
Hit http://ftp.debian.org jessie/contrib armhf Packages
Hit http://ftp.debian.org jessie/non-free armhf Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Ign http://apt.osmc.tv jessie/main Translation-en
Fetched 6719 B in 38s (172 B/s)
Reading package lists... Done
root@Sin:/home/osmc# sudo apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  apt-transport-https libbluray1 libgssapi3-heimdal libheimntlm0-heimdal
  libkdc2-heimdal rbp2-image-4.4.3-3-osmc
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@Sin:/home/osmc# reboot

read it here → http://kodi.wiki/view/Kodibuntu#How_to_upgrade_Kodi

Ah, Kodibuntu is not OSMC.

Maybe when we do our x64 port we can take that spot :wink:

We’ll see.


ooops, sorry.

Do you think that at this point I should rebuild?

Well interesting enough no one has asked you the basic question, which skin are you running?

Try mv .kodi .kodi_backup and reboot

Using Arctic:Zephyr

Oh my god, that actually worked! I’ll try to recover what I can from the backup and see what might ha ve caused the crash (be it addons, theme or what not). Thanks! :smile:

No need, that was just to find out!
Just do

sudo systemctl stop mediacenter
mv .kodi_backup .kodi
nano .kodi/userdata/guisettings.xml
search for the line starting and change it to <skin default="true">skin.osmc</skin>
Save the file when exiting with CTRL-X
sudo systemctl start mediacenter


Perfect, thank you so much!
Artic:Zephyr crashes when I try to select it as theme… I’ll try to re-download and install it.

Thanks all, and excuse the n00b thread :slight_smile:

Seems to be a problem with OSMC Kodi 16.1

Just to put my two cents here. Same problem, same symptoms. And your solution worked flawlessly. It seems Arctic:Zephyr is broken for the current OSMC release. A pity, but better this than reinstall.

Thanks A LOT for the help.

1 Like