Kodi crashes when selecting Music view

I purchased a Vero 4K+ recently and upgraded from a RPi3B.

I made a KODI backup in my RPi and restored that backup on the Vero4K+. I immediately lost sound. I renamed the .kodi folder and restarted the Vero and the sound came back. I transferred over my advancedsetting file to connect to my network shares and shared database.

Whenever I move over to the music view (using the Estuary skin), KODI crashes. I get the sad face on a blue background. I don’t have to be in that view for long… just clicking through to the next view will cause KODI to crash.


did you happen to restore the guisettings.xml from the RPi to the Vero? If so then ssh into the Vero and

systemctl stop mediacenter
rm ~/.kodi/userdata/guisettings.xml
systemctl start mediacenter

Then check if your issue is resolved. If it is then you will need to setup all your settings again as that is what you just deleted and cannot be exchanged between those two systems.

When I renamed the .kodi directory and restarted, I would assume it would recreate the guisettings.xml file when it recreates all the other content in that folder.

I did try this method. I found it the music view does not crash under the OSMC skin but it does crash while using the Estuary skin.

Can you confirm (or otherwise) that when it crashed you using a totally fresh Kodi configuration, without making any changes, eg to advancedsettings, xml, sources.xml, etc

When I have a completely fresh copy of the .kodi directory and using the Estuary skin I do not get a blue sad face and a reload of Kodi.

I can add in my advancedsettings.xml file to have Kodi connect to my shared database and everything is still fine… however, I cannot play any movie, tv show or music as the password to the network share was not given.

All of my media mentioned above is on a shared NAS drive under the folder multimedia. Each category has its own folder under the multimedia folder. I created a network connection in Kodi to the multimedia folder with my username and password. At this point, I can play any movie or tv show. (I can play music in any other skin but Estuary) at this point.)

When I select music (only in the Estuary skin), the program now crashes as it tries to read the metadata from the music files. I am assuming that is the case as Kodi (through the shared database) had recreated everything else it needed to display the view correctly. I had artists, songs, CD cover art, etc.

I used a program called MusicBrainz Picard to sort and catalog my music collection. In some of the logs, it shows that Kodi cannot read or understand some of the metadata. It may be another issue, I don’t really know. What sort of logs besides the one I uploaded is needed to help troubleshoot the issue?

My question, is why would this view fail on the Vero 4K+ and not on any other device I own. Raspberry Pi 3B+, Win 10 machine, Android Pie cell phone.

Thanks for your help. It is appreciated.

I’m a bit stumped but the only thing I can think of is that there is some way the new .kodi/userdata/passwords.xml is being created differently than the old which is causing an issue. You might want to copy that file along with sources.xml and, if you have it, mediasources.xml from one of your working machines, reboot, and see if that fixes the issue.

Thanks for the quick response. I tried that. I took those files from my Win10 machine… same issue. I them took those files from the RPi3B and same issue.

I tried to disable all the options for the music folder under Settings --> Media --> Music to include enable tag reading but the issue remains. Ugh.

Is the Pi running OSMC?

when it crashes does the kodi.old.log always show it having hit that “CFC” folder? If so there may be a file in there that the Vero is having issue caching its artwork for some reason.

Did you “add in” your sources.xml file, in the sense that you copied it from your backup? The one in the log contains what seems to be an invalid source:

        <name>Music @Recently-Snapshot</name>
        <path pathversion="1">//w52q/Music/@Recently-Snapshot/</path>

Yes. The Pi is running the latest version of OSMC.

Yes. In each of the logs, some music in the “CFC” folder is one of the last ones scanned but it is not the last one.

Originally everything was copied over via the backup method within My OSMC. With the last couple refreshes of the .kodi folder I chose to only connect to one network share which is the multimedia folder. That folder you are references was put there so KODI would not index it when it scanned for new music. On the NAS device, it creates backups of all my contents everyday. After the 7th day, the backups are deleted.

It is something within the CFC folder. I moved that folder off of the NAS and KODI music view worked. I will look at the artwork in that folder and see if I can’t reinclude that folder later.

Thanks for your help.

1 Like

Now that I know what file is causing the issue I was curious to know a couple things. It became obvious to me that the Estuary skin searched out the media while other skins did not automatically search and catalog.

I added the CFC folder back into the NAS drive and loaded the OSMC skin and some other skins. Every time, on the Vero 4K+ when I load in those songs Kodi crashes. It does not matter what skin I am using.

Unfortunately, on my Pi or Win 10 machine those songs are loaded with the appropriate cover art embedded in the song. At this point, it looks like these files only affect a Vero.

I believe hardware acceleration is used when it can for making the thumbnails which may explain why it is only happening on the one platform. If you can narrow down to a particular file that causes this crash on the Vero I would encourage you to share that file with @sam_nazarko so he can look into this bug.

I do have a single file that causes the issue I am willing to share.

Is it by any chance a WMA file?

No. It is a M4A file.

Okay – can you please upload a sample?


I take that back. It is the WMA files that cannot be played.

I just checked old forum entries and it seems someone solved the problem when using kernel based SMB mounts instead the Kodi internal way. While it is totally not clear why that is Only a OSMC propblem it would be interisting to see if fstab mount solves it.

Maybe for testing purpose do a kernel base mount (either fstab or autofs) for the folder that contains the WMA file.


I can confirm a couple things.

  • WMA files cause the issue

  • Mounting the server folder via the Kodi method will cause Kodi to crash

  • Mounting via fstab does not cause Kodi to crash. It also shows all metadata for the music. Unfortunately, this method will require the use path substitution for my shared database.

  • I did not try the autofs method but will if further testing is warranted.