KODI dual Audio Patch from KODI Forum in OSMC


I use a Hifi Berry digi+ with my Pi2 to send digital Signal to my Onkyo AVR via Toslink.
Unfortunately, I need analog Output (Outdoorspeakers at Zone 2 of AVR), because my AVR can‘t forward the digital Input to Zone 2 :weary:

is it possible to implement the dual Audio Patch from [forum.kodi.tv][1]
[1]: [Project] Dual Audio Output support (Nexus/Matrix/Krypton/Jarvis/Isengard/Helix/...) in OSMC?
I‘m new in Linux Things and don‘t know much about compiling…
My first Pi runs well on OpenElec. After buying the new Pi2, I compiled OpenElec (Helix 14.2) with dual Audio from Github Source in the link. Works great but I like OSMC too…

If there is a possibility to do, can somebody help me with this!?!?


I’m pretty sure dual audio is supported natively on the Pi Check audio settings, you will have to change to advanced settings to see it

I’m on advanced…
But I ca only choose analog / analog&HDMI / HIfi Berry as Outputhardware.
When I choose the Hifi Berry, there is only the Passthrough Option to HIfi Berry or HDMI.

In this case, the Jack is silent…

So, that’s not an Option for me.

I need simultan audio Output digital and analog.
With patched OpenElec, it’s posible.

analog&HDMI is dual audio. Not sure about add on sound cards though

You are right, but as discribed in the first post, I use the Hifi Berry digi+ for digital Output and won’t miss it.
In patched OpenElec I can choose two several Audio Outputs (analog AND Hifi Berry).

Again the Question, is it possible to get this option in OSMC.
Maybe by choosing Code from the patched KODI branch .

I have the same issue and would love this feature. My setup is

Raspberry Pi2 ->HDMI -> Pioneer AVR Zone 1 (TV Room)
Raspberry PI2 -> Analogue (3.5mm jack (on PI) to double phono cable)-> Pioneer AVR Zone 2 (Kitchen/Outside)

I know I can do a single zone at a time or have it on analogue only but then I loose surround sound in zone 1 and its not convenient to be changing between analogue and digital all the time.

I can set audio to analog&digital (Jack&HDMI) on Pi. This works for me. But not with hifi Berry as digital out.

Is it possible, that your AVR is only 5.1?
In this case, you will loose Surround Sound anyway with Zone 2.

Hey Fix666

Nope my AVR is 7.2 (5.1 in sitting room, with stereo in the kitchen). The last time I tried to set both analogue and digital simultaneously it worked but it prevented surround sound (Dolby, DTS) etc from working in zone 1. I believe this is a short coming with the default media player used in Kodi.

That’s exactly like my Lineup…
But I use digital Sound of Hifi Berry digi+

Just to add to this, I enabled dual audio last night and when I play a movie file (DTS/ AC3 5.1) I get a blank screen with no audio or video using pass through on the HDMI cable. I also set omxplayer as default in the advancedsettings file and the same thing happened. I am starting to consider a DAC and HDMI splitter combo might be the answer.

Firstly Fixx666, apologies for hijacking your thread but I thought it was similar to my issue…

Anyway for completeness sake and in case it may help someone, I had a play again and it seems that when you enable dual audio through the audio output device setting, I get zone 2 analogue working but it disables passthrough hence it impacts AC3/DTS passthough to my AVR. I can play DTS/AC3 movies in stereo while this setting is enabled but i’d rather not.

Credit where credit due…To Sam and team, thanks !

I checked my set up post the recent update and I now get passthrough using “Analogue + HDMI” as my audio setting hence I can permanently leave this setting in place while enjoying AC3/DTS in my Zone 1 and Stereo in my Zone 2. For those who wish to have non-stereo sources in Zone 2, I would recommend an audio extractor/converter plugged between their RPi and their AVR.

As analogue audio and passthrough are not compatible, we used to disable passthrough if analogue was enabled (including Analogue+HDMI). I’ve changed this to disable analogue when passthrough is enabled and actually used.

That seemed to make more sense where videos were played with passthough through a receiver and analogue was mostly used for music.


Sorry to revive an old thread. I’ve got an Iqaudio card and I’d like to run both ALSA/Iqaudio plus HDMI sounds output at the same time. This is because for general viewing by my family HDMI audio is fine but I’d like to be able to turn on my amp and use iqaudio for music and some movies.

I’ve tried enabling ALSA as primary and then pass through to HDMI but that hasn’t worked. Is there another way to have both audios running at the same time? I’ve found the json script to toggle between ALSA and HDMI which would be a solution to make switching quicker.

Any info would be great.