Kodi hangs on playback start

Was about to post my own thread here, but I think this might be the same issue. After installing the latest update I noticed that my Vero 4k+ sometimes hangs when i start playing a video. Sometimes just when one movie just ended and i try to start the next (same decoding), sometimes when i been playing music and try to play movie.
Visually, I press start, the spinning wheel shows up and just keep spinning. Most of the time it stops if i press the stop button, and if i press play again it starts spinning as before.
Only way to solve the problem have been to press the power button.

My Vero/OSMC reads the files form my Synology NAS, properly setup and have been working flawlessly since i got advice here on how to set ip up properly over a year ago. I have not made any recent changes in Router configurations or other hardware.

Busy looking for a new apartment now, but I will try to upload a log file in the coming days.

It does not sound like a related issue from your description.

If I were to assume your using Kodi SMB paths and it is related to a known issue, then I would suggest to either make sure your NAS and Kodi is configured to use SMBv3, enable settings>services>SMB client>Mitigate MTU issues with SMBv2, or switch over to system mounts. If your not using Kodi SMB paths, or you have already done one of those three things, then we would need to see logs.

I just read about the previous SMB issue and was about to update my post - I run nfs via autofs
have started loggin now, and running some videos in the background “hoping” to catch the error.

OK, so I played a couple of short TV episodes. (wife was watching TV - not using kodi)
Did the controlling by the Official Kodi remote, and noticed after the third episode was ended that the “running count”, or current location shown to the left in the remote showed 30 mins, but the episode itself is only 24:37 long… somehow it just seems to have kept running (the screen only showed the spinning circle and the episode list.
i pressed stop on the real VERO remote button and started again, but only seeing the spinning disk. when I look at the Kodi remote, it looks as if the video is playing and the seconds ticking away.
I pressed stop again but now could not get back to manu and had to do a reboot by the power button before uploading the logs: https://paste.osmc.tv/ovixavevax

You didn’t have debug logging turn on, so the log doesn’t show much of what happened.

Does this happen only if you use the Kodi remote?

As a test, could you turn off the UpNext monitor, and also disable Spotify?

Also, you say that you are using autofs, but from the log:

2020-06-27 13:36:20.060 T:4066729984  NOTICE: VideoPlayer::OpenFile: nfs:// in the Shell - Stand Alone Complex/-season 3/[DragsterPS] Ghost in the Shell - SAC_2045 S03E12 [1080p] [Japanese Audio] [Multi-Subs] [5FDF2F37].mkv

it shows you still using Kodi mounts.

Don’t know what happened there, I WAS in the debug menu and I did turn it on, must have accidentally have turned it off again… redid it and this time i see it running as I started a new video.

This was the first time I used Kodi remote, the only reason was so that I could start new videos while my wife was watching TV. Before its always been with the VERO remote.

Done - UpNext is only annoying me anyway…

This confused me a bit - I do have a properly configured autofs in the etc folder. Need to look at that of course, but the main this of that statement was that I am not using SMB.

Will upload a log as soon as I get into new troubles, so far it seems to have been after abt 3-4 episodes.

You do have autofs mounts from what I can see in the logs, but your sources are still using the Kodi NFS mounts. You only seemed to have added your music as a source using autofs, everything else is still using Kodi.

I really doubt that that is your problem, but I thought I’d point it out to you.

its appreciated - I really did think all were mounted through autofs. I did have a number of issues with my Synology NAS last december and ended up with long discussions with their support. Later I bought a second NAS - now music is on the old NAS and other media on the new.

Auto.nfs.shares contain:


(still waiting for an error to show up on VERO…)

Yes, you have mounted your shares via autofs. But you have not updated your sources in Kodi nor used path substitution.

See the differences in your sources

    <path pathversion="1">/mnt/Music_NAS/</path>
        <path pathversion="1">nfs://</path>

Thank you, so this one below is how thewy all should look like if i understand it right? Pointing to the automounted source and not right to the server?
Of course with the correct name for each mount…

Correct and afterwards need to clean/update your library

thanks, will do that after i got a decent log to show the first problem

… or not. it might have been the NextUp or spotify plugin that caused the issue because after at leat 10 episodes everything still plays fine.
i will plug them in one by one and see what happens now.

I would highly recommend not editing your existing source as you’ll duplicate everything without a easy way to fix it. I would either make a new source for the system mount and then remove the original source telling Kodi to remove everything from that source from your library or just skip messing around with your sources entirely and just use a path substitution.

Now that the issue appears to have gone away have you tried replaying the same files that had issues to see if the problem was actually the files themselves?

I have moved these posts to a new thread as the issue is unrelated to the one it was started in.

Thanks, I was thinking the same thing - I suspect NextUp to be the culprit but have not had time to test it yet. After I turned off NextUp and Spotify and started the debug We have played at least 5 episodes (the same as before plus more from the same series that didn’t work before ) of Anime, 1 full (rubbish) movie and another TV episode with no issue at all.
The Amime series themselves I have already watched on other players (VLS on iMac and Infuse on ipad) without issues.