Kodi issues with scraping and subtitles


I have a problem since a few weeks now.
Raspberry Pi 4 Model B Rev 1.1.

Here is the log from grab-logs -A, but bugged somehow:

New added Movies and TV Shows are not scraped. But I can access and read them from the Video sources.

And I am not able to download subtitles anymore - the error message is that I apparently do not have any account. I just tried to uninstall Opensubtitles.org (which was installed) to download it again - the uninstallation worked apparently but impossible to download again. Same for any other add-on from the repository - it fails.

Any idea ?

Thanks a lot.

So no URL was shown at the end of it?

All of this sounds like network problem.

What is the output of

ping osmc.tv



Output of
I had to interrupt it after being hung for a few minutes.

Output of osmc.tv
Same here

But I can download, generally speaking.


This is very very odd.

What does ip ro give you

Opensubtitles.org has been replaced with Opensubtitles.com
Create an account at Opensubtitles.com then install the opensubtitles.com add-on and enter your account info.

1 Like

Thank you BanditRider, that works now. One less problem to solve :wink:, thanks.

interestingly, I just tried again the ping and it looks fine (same for ping osmc.tv):

193 packets transmitted, 192 packets received, 0% packet loss
round-trip min/avg/max = 38.831/117.917/184.546 ms

That’s why I tried to download the Opensubtitles.com and it worked. Weird… Must have some unstable connection :man_shrugging:

Still, here is the ip ro output: via dev tun1
default via dev eth0 via dev tun1 dev tun1 proto kernel scope link src dev tun0 proto kernel scope link src via dev tun1 via dev eth0 via dev eth0 dev eth0 proto kernel scope link src dev eth0 scope link

I still have the scraping problem though, even with both TheMovieDatabase and Universal Movie Scraper.

Is this an older library and the shows that have scraping issues being ones that had existed in the library since before a major Kodi update? If so then the issue is probably they are set to source from TVDB and the update dumped the old non-working versions of the TVDB scraper and then Kodi defaulted back to installed scrapers. The solution would be to install the updated TVDB scrapers and then set your sources to use these, or else update you library to actually use the new source. I would recommend against switching to the universal scraper as it seems to be a bit more prone to issues. Switching the whole library can be a matter of dropping and rebuilding your TV show source, or can just be going to each of the shows with the issue and bring up the info screen (for the show, not an episode) and click the refresh option. If you have nfo files they would need to be removed or else they will just bring the wrong source back in.

If you want more details you can search the forum. I’ve covered this type of thing quite a few times now in detail.

Thanks darwindesign,

I have de-installed my movie scrapers and re-installed them. Sounds stupid, but I should have done that earlier. Seems to work fine now.

Thanks a lot for your time guys !!

1 Like

Gut feeling is that you had (or have) a temporary issue with your network. That combined with the outdated subtitle/scraper settings confused a bit the resolution of the problem

1 Like

Yes, that must be the case. I don’t stream via the platform probably I don’t see the problem (luckily). Thanks a lot again for the help