Kodi.log - No correct GMT it's setted

I have look at my Kodi.log… right now i see the last line:

12:36:52.698 T:1925884416 NOTICE: VideoPlayer: finished waiting

I see the timing… it’s one hours backward. From SSH session and command date apparently the GMT it’s correctly setted apparently.

How i can configure or check this ?

It should be the same as the time you see on screen.

Settings–Interface–Regional–Timezone country

mmmmmm… apparently no… i have correct set my timezone on kodi but on log files all event’s it’s one hours backward.

You thinks it’s not a GMT trouble ? It’s probably on log it’s used GMT and in kodi it’s correctly used GMT+1…

If I set my clock to GMT+1 then the log changes, but haven’t tried on Pi - maybe that’s different.

Perhaps your last activity in the mediacenter was an hour ago? The log on my Pi2 shows me a last entry from yesterday in the evening.
Try to reboot, login via ssh, check the current time, upload logs using sudo grab-logs -A and look with the provided URL in the in the system journal for the last entry whether this matches around your current time in the ssh session.

No… i have also try on reboot.

For example if i reboot my Pi2 right now… it’s 17:43 and on kodi.log report simply one hours backward…

For example today i see on my log:

14:12:37.597 T:1926269440  NOTICE: Raspberry PI firmware version: Jan 31 2018 18:12:16 
                                            Copyright (c) 2012 Broadcom
                                            version 02bc3b27e848b39400b1685b6d24b3bca45dffcb (tainted) (release)
14:12:37.597 T:1926269440  NOTICE: ARM mem: 768MB GPU mem: 256MB MPG2:0 WVC1:0
14:12:37.597 T:1926269440  NOTICE: cache.memorysize: 200MB libass.cache: 0MB
14:12:37.598 T:1926269440  NOTICE: Config:

Today i have turned my Pi2 now at 14:12… but approximately one hours later.
At 14:12 today i see some normal DDT TV.

It’s very strange because via SSH session the time it’s exact:

root@osmc:~# date
lun 19 feb 2018, 17.48.21, CET


I have an idea… usually i use FTP Client… also on FTP client i see the last time of modification it’s also show an hours backward.
It’s my FTP Client ?? I need to set the time also for FTP setting on my Pi2 ??

Wait a moment… There’s a setting on my FTP Clients… about Local Settings.
Now i change this settings… In default “Try to catch automatically the Local”, now i have set “Use Server hour”.

I need to see what’s append right now…

  • EDIT 2 *
18:03:27.243 T:1926269440  NOTICE: VideoPlayer: Opening: https://r6---sn-hpa7zne6.googlevideo.com/videoplayback?itag=22&ipbits=0&lmt=1518720192419638&expire=1519081404&mime=video%2Fmp4&key=yt6&fvip=6&c=WEB&mm=31%2C29&mn=sn-hpa7zne6%2Csn-nx5cvox-hpae7&mt=1519059723&mv=m&signature=D2D95D2D80AB453B4E6AC098E716B3246AB5E1A5.DE3DCC9902399E1864F289424808319B89D0400C&ms=au%2Crdu&sparams=dur%2Cei%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cnh%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cexpire&ei=WwOLWrSTOsOj1gLA7bKwBQ&ip=|Cookie=PREF%3Dal%3Dit%26f1%3D50000000%3B%20VISITOR_INFO1_LIVE%3D6oJHDHLRmws%3B%20YSC%3DWKXPEXDE99M%3B%20s_gl%3De60a98207fabbf6626d6b2615347cf06cwIAAABJVA%3D%3D%3B
18:03:27.243 T:1926269440 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:03:27.401 T:1030738688  NOTICE: Creating InputStream
18:03:27.810 T:1030738688  NOTICE: Creating Demuxer
18:03:27.960 T:1030738688  NOTICE: Opening stream: 0 source: 256
18:03:27.961 T:1030738688  NOTICE: Creating video codec with codec id: 28
18:03:28.006 T:1030738688  NOTICE: Creating video thread
18:03:28.007 T:1030738688  NOTICE: Opening stream: 1 source: 256
18:03:28.007 T:1030738688  NOTICE: Finding audio codec for: 86018
18:03:28.008 T:1194320640  NOTICE: running thread: video_thread
18:03:28.011 T:1030738688  NOTICE: Creating audio thread
18:03:28.012 T:1177543424  NOTICE: running thread: CVideoPlayerAudio::Process()
18:03:28.012 T:1030738688  NOTICE: Opening stream: 0 source: 1024
18:03:28.073 T:1177543424  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 44100, no pass-through)
18:03:39.715 T:1194320640 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

OH MY GOD!! It’s my fuc***ing FTP client!!! It’s only and ever my FTP client!

I use FlashFXP!! IT’s have a Local settings!! Now it’s correctly setted and look at here!!
I’m right now stay to watch a youtube video and look!! The time it’s correct!!!

But damn!! oh my god again… he drive my crazy this little issue and boom :slight_smile: The solution it’s simply here…

1 Like