KODI not playing any video content after 18.9 update

Hi, After update to 18.9 my Vero4k+ refuses to play any content, whether that would be from local mounted HDD or streaming.
The player tries to start but I will only get “Buffering” message in the top right corner and after that I can see timer running but on the screen I can only see OSMC animated sign.

Logs are here

Any help much appreciated.

1 Like


Sorry – slight mistake at my end.
I’ve pushed a fix, but it will take just under an hour to reach you via the update system.

I’ll let you know when this is ready.


No worries, thanks for the update.

I’ve just had the update which has fixed it for me. Thanks


The update has now propagated.

You can resolve the issue by going to My OSMC -> Updates -> Manual Controls -> Check for Updates now and installing the update.

Please let me know how you get on.

Sorry about this! I can appreciate that in the evening you want to watch TV and not twiddle your thumbs waiting for an update.




Thanks for confirming.

1 Like

So I turned on my TV and the Vero greeted me with an update ready message so I said okay and it did it’s thing.
After the update it wouldn’t play anything, just buffering.
Grabbed logs, took a video with my cell phone and hopped on the forum ready to post my issue and found this thread first.
Followed the instructions and did another update.
Everything working as normal again.
Just wanted to chime in and confirm it the fix worked for me as well.
Thank you sooooooooooooo much for the quick fix Sam and team!


All good over here as well.

Thanks Sam for speedy response :partying_face: