Kodi not showing all files on SMB share

I’m having an issue with OSMC that not all files on an SMB share were visible on Kodi. On all of my shares some files are missing. The missing files are alphabetical continuous till the end of the alphabet. I cannot use the File manager to see this file, nor update library is working on them. The ones which are in the library are no longer playable.
The shares are 4TB and have no subfolders.


I don’t understand if you cannot see them visually (which might explain why there’s an invisible entry highlighted in the screenshot) or the list just actually shows those files only.

Is “smb://Homserver” a windows machine or linux? If it’s linux, did you check the owner:group/permissions on those files?

@ActionA Homeserver is a Windows machine.

@TheHacker66 When I access the share from a Windows client it shows all files. When I access the share from OSMC it is not showing more files than “This is 40.mkv”, when I delete one file bevor “This is 40.mkv” it shows one more file “This is where I leave you.mkv”.

Have you tried using another skin and seeing if it shows everything?

Yes, and I also tried a new installations with different releases of OSMC

I 'm not sure to understand.
What is your (Kodi) problem.
Can you can see your movie (file) in the Kodi folder view, but not in the scrapped Kodi “mediatheque” ?
You can install the add-on Missing movies to see the list, or take a look directly in the Kodi folder view ( ??? skin ). It’s not the same icon for scraped “mediatheque” files, and for basic folder movies.
If you found your files it’s probably not a SMB issues, but has something to do with your metadata.
And then Kodi log is your friend.


I cannot see the movies files in the file Manager. On the kodi screenshot the last movie file is “this st 40.mkv” in the Windows Explorer Screenshot you see that there are much more files in the SMB share.

Forgot windows.
you must take a look inside Kodi. I don’t know your skin.
When you select your source movie folder, you can open this folder, ans the you see the differents files , with differents icons,
Perhaps pour better understanding try first to install the Kodi extension missing movies, and stgart the movie option. When you see here your files it’s a KODI problem

The SMB shares are ReFS on Windows 2012R2, when googling, it seems that there is an issue connecting Kodi to ReFS SMB shares. Is this still a Kodi issue? Is there a workaround?

We believe this is a Kodi issue or a specific Kodi function and as such you should look at addressing the issue there. We are unable to resolve your issue. If you do believe that this is an OSMC specific issue, please let us know.