Kodi v18 release build: playback stuck on last few frames of previous played recording

#1

I upgraded my Vero4k+ yesterday to test these builds before official release. I was previously running the gmc-19 builds without any problems.

I also noticed a kernel bump when i upgraded (from vero364-image-3.14.29- 140 -osmc:arm64 to vero364-image-3.14.29- 142 -osmc:arm64)

I watched some livetv and recordings last night without any problems. However, this morning I tried to play both livetv and recordings and the Video was frozen on the last few frames of the last recording we watched last night; although the Audio was playing correctly.

I was able to hit stop to return to the gui, but whenever I tried to play anything it just showed those same last few frames from previous recording last night.

Here are the logs: https://paste.osmc.tv/cedecekoda

I rebooted and this cleared the problem. I also took some screenshots should you need them.

[TESTING] Kodi v18 release builds
#2

I noticed the same thing (with the same resolution) while I was running the nightlies. It only happened once from what I can remember, and I didn’t have debug logging on to capture the issue, so I just figured it was the cost of being way out on the edge and moved on. So this was really just a log way of saying you aren’t crazy, I’ve seen the same thing too. '-)

#3

I also have noticed this problem with PVR recordings. Mostly 1080i MPEG2 files. Video will be in slow motion while the audio plays fine. Problem is intermittent and a reboot will fix the problem temporary.

Using NextPVR addon.

#4

Interestingly I also use NextPVR. If the original poster is also using NextPVR that might point towards a problem there rather than with OSMC. Or maybe something odd with NextPVR on OSMC at least.

#5

I thought about a NextPVR issue so I updated my Windows box to the latest version of NextPVR
software. The addon has not been updated recently so it’s really hard to say. I never noticed any issues with the gmc-18 nighties but i stopped once they switched to 19. I’ll see what happens and report back. I’ll try and get some logs also.

#6

Negative…I use Tvheadend

#7

Does this only happen with transport streams?

#8

For me its happened once so far and that was indeed a transport stream recording from tvheadend.

Its not occurred again for me as yet. Debug log was attached to my first post, and will attach further logs if i manage to capture it again.

#9

Both mine (it happened again yesterday) happened when watching LiveTV, and I’m pretty sure that’s a transport stream with the NextPVR PVR addon. It happens so infrequently I haven’t been able to catch it in a debug log yet. What’s interesting is that simply exiting Kodi and letting OSMC start Kodi back up doesn’t help. I have to completely reboot the Vero 4K+ to clear it.

#10

I noticed the same