Kodi v20 and Subtitles with SMBv2 Enabled

Started this new thread. Originally from OSMC’s June Update is here with Kodi v20 - OSMC thread –

When I attempt to browse for a subtitle file and select the file the system crashes (sad face). The problem is repeatable for me and just started after v20 upgrade. I attempted to:

systemctl stop mediacenter 
rm -r ~/.kodi/temp 
systemctl start mediacenter

This did not help.

I also attempted to rename my subtitle file from English.srt to the name of the movie.name.eng.forced.srt. Now playing the film crashes the box before I even attempt to select the subtitle file. This issue appears to be repeatable with any mp4 file with an srt file for its subtitle. I am not having this problem with mkv files that have subtitles built into the mkv file.

I also have a Kodi v19 vero-4k+ box that I have not yet upgraded to Kodi v20 and this is not occurring on the Kodi v19 vero-4k+ box.

I have log files I can upload or send (the upload in this webapp only allows for image file uploads and not log file uploads) from both v19 and v20. There are a few subtle differences that may provide a clue as to what is happening. The v20 box does have a PVR add on, but this was occurring before that add on was enabled.

There is nothing unique about my configuration and doing a fresh install seems a bit drastic. I have to believe others will likely see this issue if they start playing subtitled films on kodi v20 or a vero 4k+ box with kodi v20 installed. If you can say that you have fully tested this use case, then I am willing to try a fresh install.

And still no logs. If you need to sanitize them this is covered in this guide…

If this were factually true then there would have been a large number of people posting about this issue by now. There has been zero reports other than your own and, as previously stated, I tried to reproduce using the same file your playing and cannot. I even tried on two different platforms.

The suggestion to consider a fresh install was only because you seem to be unwilling or unable to provide any information that would allow someone to provide a better suggestion.

I have kodi logs from both a v19 and v20 box Vero 4k box. If I click on the upload icon in this reply box, it only let’s me upload image files (gif, jpg etc). .log files cannot be attached to this dialog. I did send these logs via email to a support ticket I opened. The how to article does not really explain (at least to my dense brain) how to get these logs directly into your hands.

If more than kodi.log files are needed to troubleshoot the issue, can you suggest what files would be helpful and the paths? I don’t see any other log files in the .kodi directory.

I would like to try to solve this without a fresh install. I have three Vero 4K+ boxes and do not want to upgrade the other two until I understand how to make this work correctly on the box I upgraded to.

Apologies if I am sounding rude. I am really only frustrated with the situation and appreciate your help.

I’d suggest rereading the link that was provided on how to submit a useful support request. There is very specific information in that link about what to do with the log files to get a URL that you can post here.


Tested here. There’s a specific add-on that has a problem, but that’s add-on specific and can’t be named here. The issue also exists in v19.

@pkscout @sam_nazarko Thanks for replying. I will plan to do a fresh install next weekend. I re-read the how to submit article and have uploaded logs.

For my Kodi 19 box, they are at: https://paste.osmc.tv/kuwuhisado . For my Kodi 20 box they are at: https://paste.osmc.tv/efohafuham . If you can provide any better guidance based on these, I thank you in advance. I do have a PVR plug in on the Kodi 20 box that I do not have installed on the Kodi 19 box, but it would surprise me if a plug in is interfering with subtitles.

I have submitted general questions to this forum, but have never needed to submit logs, so I appreciate your patience :grin: .

Try changing system>services>smb client>Mitigate MTU issues with SMBv2 to disabled and see if that makes the crash go away.

On a different note you should enable settings>player>videos>allow hardware acceleration.

And on a completely unrelated note you have two subtitle add-on’s installed that don’t seem to work. I would uninstall them and just use opensubtitles.

@darwindesign The SMB setting fixed the issue. I remember having to set this years back when my router did not support later versions of SMB. Everything worked fine with SMBv2 enabled until the latest upgrade. I am probably a very small sample of your user community. Many thanks for your help!

1 Like

Your welcome.

@sam_nazarko it looks like there is a bug that came in with Kodi 20 with your mitigate MTU issues with SMBv2 patch that is crashing Kodi on external subtitle load. I was able to reproduce.

Yes – time to remove this option now (not needed).

I conflated the subtitle issue with another add-on which crashes when you try and select a subtitle.



Hopefully the issue is now addressed with the following commit:

Please note that this is based on Kodi v20.2.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

1 Like

Hi @sam_nazarko - I did the upgrade. I am no longer seeing the “Mitigate MTU issues with SMBv2” option under Services->SMB Client available, which I believe was what you are trying to accomplish. I also see no adverse effects. Everything still plays correctly with subtitles. Based on this I would support you releasing this :grin:


1 Like

Thanks for confirming. In to the next update it goes.