KORE remote no longer connects to Vero4k+

KORE remote, the official remote for Kodi, worked fine for a long time but over the past few days has stopped connecting to the Vero4k+ even after being rebooted a few times. I can still connect via web browser.

Has anything changed in the updates that would cause this to happen?

No, check that IP address has not changed and that port/username/password are configured correctly

TY for the response.
The IP address is still the same as always.
I have not changed anything for port/username/password.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

No one asked if you changed it. We’re prompting you to confirm that this config is as you expect, in Kodi and in Kore.

Being a “tech-tard”, i have no way of answering your question " We’re prompting you to confirm that this config is as you expect, in Kodi and in Kore."

What I can confirm is that
1, I know the IP address and the proper IP address is in the Kore Remote
2, Kore Remote tries to connect to the proper IP but stays in the :Connecting:
3. I can connect to the Vero at the IP address via web browser.
4. Being a Tech-Tard I have made no changes on my end.

If you would post logs like @fzinken asked you to do that would give use something to work with. We could then see the IP and the port that are in use.

I think you are now obliged to use a user and a password. Before It was not mandatory. You could leave the fields empty

I had the same problem when I installed the 19.1 version.

Hope it helps

1 Like

Last night I was not near my Vero unit so I could not send the logs
Here is the debugging log as requested


I can transfer files to Vero using Finder on my Macbook
I can SSH into the Vero using Terminal on my Macbook
I can access Vero via Web browser

When trying to use Kore Remote, this is what I see


I removed the original set up and tried to set up connection to Vero4K+
but this is what I see


You need to look into the remote access configs in Kodi. If you search for the documentation for the Kore app, it will provide the necessary Kodi configs to achieve function.

Are you sure your phone is in your LAN?
Can you access the Vero from a Webbrowser on the phone you have Kore installed?

1 Like

TY for the help.
The problem must have been stupid user device error

I did the following:

  1. reset the network (first time in over a year)
  2. uninstalled Kore remote
  3. reinstalled Kore remote
  4. rebooted phone (first time in over a month)
  5. set up Kore remote

Now it works.
It must have been a glitch on my network with my phone

Now another odd thing happened.
On the Kore remote app I got a message to change the default password (osmc/osmc) due to some data breach on some website. I changed the username and password.

All is good now.

Thank you again for the help.