Kore, ssh and Webaccess not working

First of all, hi there, I am new here and also new to OSMC.

Just got the Vero 4K some days ago and already some issues:

  1. Tried to login through SSH, this is not working, ok, tried to switch to console from OSMC (press ESC while booting), unfortunately also did not work. What am I doing wrong ? (only wanted to mount the share through fstab)

  2. The device is not seen in my network and also not accessible through web interface although settings are allowing the access. Not even the Kore app on my phone is working… any suggestions to that?

Thank you for the appreciated help


How are you connecting to your network? Wired or wireless?
Check the System settings of the Vero to see if you’re connected to your network.

Do you have SSH and the web server turned on?

Hi, ssh and webserver are on, network is cabled and connection to internet and NAS is ok.

What do the network settings show in MyOSMC? Can you ping it by IP. By name?

Destination host unreachable (wired)
Network settings looks ok, eth0(connected)

Please, provide a log set: How to submit a useful support request

If that is also not working, check in the GUI, whether your OSMC device has got an IP in your network or perhaps is isolated in a guest LAN or even got a zeroconf IP (starting with 169. …)

Will do so tomorrow, the IP shown in OSMC is also shown in the router’s overview, therefore should be set up properly.

Try a different network cable.

Just did a quick test, ssh and web Access is working when using my desktop PC which has wired connection, unfortantely, I did not have time for more…


Since yesterday, the Kore app on my mobile connected to the Vero, I then tried SSH which now also works.
I did not change anything at all, seems that the issue somehow is now fixed.
(Well lets see for how long…)