Krypton broke SFTP

Since I updated to krypton I cant connect via SFTP.

SSH is still working flawless, but Bitvise (Windows) and FolderSync (Android) cant connect to the server.

19:56:45.839 Current date: 2017-02-14
19:56:45.839 Bitvise SSH Client 7.24, a fully featured SSH client for Windows.
Copyright (C) 2000-2017 by Bitvise Limited.
19:56:45.839 Visit for latest information about our SSH software.
19:56:45.839 Run 'BvSsh -help' to learn about supported command-line parameters.
19:56:45.839 Cryptographic provider: Windows CNG (x86) with additions
19:56:46.033 Loading last used profile 'C:\Users\JonnyB\OneDrive\Documents\Bitvise Client Profiles\osmc.tlp'.
19:56:46.035 Last used profile loaded successfully.
19:56:46.797 Started a new SSH2 session.
19:56:46.802 Connecting to SSH2 server osmc:22.
19:56:46.832 Connection established.
19:56:46.932 Server version: SSH-2.0-OpenSSH_6.7p2
19:56:46.932 First key exchange started. Cryptographic provider: Windows CNG (x86) with additions
19:56:47.047 Received host key from the server. Algorithm: ECDSA/nistp256, size: 256 bits, MD5 fingerprint: 28:18:d9:c6:51:2b:56:83:26:12:a8:24:35:c2:ba:59, Bubble-Babble: xeler-pezyp-mynoz-caguk-cizeb-votuz-pevyv-bifem-pymut-cytid-foxux, SHA-256 fingerprint: Ew/XscQVywrdJ+1C0jj6iyXKha8ZaC166Te2eItSZQA.
19:56:47.056 First key exchange completed using ECDH/nistp521. Session encryption: aes256-ctr, integrity: hmac-sha2-256, compression: none.
19:56:47.067 Attempting password authentication.
19:56:47.102 Authentication completed.
19:56:51.357 Terminal channel opened.
19:56:56.176 Terminal channel closed by client.
19:56:58.087 SFTP channel opened.
19:56:58.105 SFTP channel closed by server.

On Android the error is
The SFTP Subsystem could not be initialized

Strange. SFTP working just fine with my system.
Haven’t you changed anything ?

sftp is working fine here also.

Nope, nothing changed, I tried uninstalling and reinstalling ssh via MyOSMC, also nothing changed.

I gave up and reinstalled everything from scratch, now it works

Since I update to Krypton I can not add share directory from server (linux) via SFTP in gui, but I take in command line it is work perfectly. Before update it was good.

Works fine here.

Thank you, but I wasn’t write that I was not found it in menu.
This functions is not work perfectly, with ‘know_hosts’ file in .ssh directory, not authenticate into a server.I use sftp noob@ command is fine good in terminal.

If it’s not working, please post a debug log. The behaviour should be unchanged.

I haven’t got more informations:

linux server auth.log
Mar 4 22:29:32 armstrong sshd[13232]: Received disconnect from XX.XX.XXX.X: 11: Bye Bye [preauth]

from osmc


As Sam wrote:

You’ll find how to do it on site’s Wiki.

Thanks for everybody, I found the problem.

Maybe you want to report what the problem was so others with a similar problem would be able to read the solution

1 Like

It is nice to ask help and be helped.
But it is also nice to share our tests and solutions, as they can help others in the future …

To help and to be helped :wink:

The Resolv.conf setting was static, but the network environment has changed.
We are not used DNS service . The SSH and SFTP services hasn’t got any problems, but sshfs crashed.

I was modified resolv.conf, after the all services are working good.