KWorld UB435-Q and Vero 4k+

I’m trying to add a Kworld UB435-Q USB-2 ATSC tuner to my Vero4k+ and TV-Headend. The USB stick is recognized by lsusb as
Bus 001 Device 032: ID 1b80:e34c Afatech

TV-Headend doesn’t see this device, although it is working with my HDHomerun tuner. Is this USB stick recognized by Vero/OSMC? Where do I go for my next step?

Drivers are reported to be in the linux kernel since 3.16. as reported by KWorld UB435-Q USB ATSC TV stick - LinuxTVWiki


What does dmesg say after recognising the stick?

Which kernel are you running?

After removing/reinserting USB stick here are the last linse from dmesg:
[ 4800.718349] em2874 #0: Identified as KWorld USB ATSC TV Stick UB435-Q V3 (card=93)
[ 4800.718360] em2874 #0: dvb set to bulk mode.
[ 4800.718463] em2874 #0: Binding DVB extension
[ 4800.736802] tda18212 1-0060: NXP TDA18212HN/M successfully identified
[ 4800.736834] DVB: registering new adapter (em2874 #0)
[ 4800.736844] usb 1-2.2: DVB: registering adapter 0 frontend 0 (LG Electronics LGDT3305 VSB/QAM Frontend)…
[ 4800.738363] em2874 #0: DVB extension successfully initialized

The kernel is:
Linux 4.9.113-45-osmc aarch64

I also ran
sudo apt-get install firmware-linux-nonfree
but the USB stick still didn’t appear in TV Headend. Now that I removed/reinstalled the USB stick it does show up in TV Headend

So problem solved?

This is solved. On to stir up the next problem…

We’ll see you then :slight_smile: