Large audio sync problem

When playing video files (var. formats)I get audio stuttering for a while then it seems to settle down, unless I fast forward etc.
On the logs I see a lot of large audio sync errors.
I have 2 vero’s networked together the second one doesn’t seem to have this problem the server ones does.
If I copy the file to a local disk it still happens.
logs at
any Ideas what I can do to stop this?

Please enable Adjust Refresh Rate to Start/Stop.

That was quick Sam, thanks that seems to have cured it.

Glad to hear. For smooth playback, we need to adjust the output frame rate so that it matches the audio (which is what we’re doing when you enable this option)


spoke too soon, started again so I set it to always. None done it again yet but will keep a eye (or ear) to it.

nope still occurring. maybe not as bad but still same error occurs about 20 times

Few issues:

  • OpenVPN seems to be consuming resources, as is an add-on called Indigo.
  • Debug logs aren’t enabled so can’t see further as to what’s going on.
  • How is the attached drive formatted?

Sorry for delay Sam, Have disabled indigo, but still doing it. would have deleted it but there’s a add on that uses it, so it won’t let me uninstall, will try to find another source so I can get rid of indigo.
Will enable debug logs and the drive is formatted ex fat. I know there’s a better file system but not sure what it is and how to format my drive to use it. I do have a spare 1tb ssd which I plan to use so I could format that if you can let me know how. Will have to investigate in the morning as the telly its connected to has been commandeered by the other half.

Is it happening on more than just the one movie?

Yes, it happens on films and other programs.
Most are mkv but others are mp4 and avi

Have you tried playback from another source other than your hard drive to rule out an issue there?


Yes Sam copied a film onto a local sd card and it was the same. Will try again in the morning with logs enabled and let you know.

Try copy to the eMMC and play.
Otherwise need to see fresh logs

Hi Sam, I copied a movie to eMMC and it happened again. I enabled logs, rebooted and at the moment it seems ok. Do t understand why as I had rebooted before and that didn’t clear it. Will keep an eye on it and let you know if it starts again.
Re formatting, how do I format my ssd to ext4 format? Don’t seem to have that option on my windows or mac pc’s

You can do it when connected to the Vero with mkfs.ext4 but when you do that you can not use it anymore on the Windows or Mac.