Last update broke Logitec Harmony IR mappings

Hi everyone,

I had my Vero4k since the new year and when I got it I configured my Harmony 650 remote (IR) to work with it, but it seems that yesterdays update broke something. After I upgraded and Vero rebooted, the remote stopped working.

I’m not talking about the Xbox profile or something similar - I found a profile for ‘OSMC Media Player [OSMC Vero 4k]’ in the MyHarmony app and it worked out of the box with the default remote profile (osmc librc). It worked great too, the button mappings were all working flawlessly.

So any idea what broke? Don’t see the point in emulating an xbox controller if there’s no need for that…

Lost of users reporting the IR broken in the latest update in other forum posts.
My self included.

I see now that there’s a related thread for the RC6-MCE remote.

I noticed my Vero is having trouble loading some kernel modules when it boots. Looking at
‘systemctl status systemd-modules-load.service’, the results are:

systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2018-03-17 12:10:11 CET; 1min 34s ago
Docs: man:systemd-modules-load.service(8)
Process: 169 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 169 (code=exited, status=1/FAILURE)

Mar 17 12:10:11 VERO4K systemd-modules-load[169]: Failed to find module ‘amlvideodri’
Mar 17 12:10:11 VERO4K systemd-modules-load[169]: Failed to find module ‘meson-ir’
Mar 17 12:10:11 VERO4K systemd-modules-load[169]: Inserted module ‘mali’
Mar 17 12:10:11 VERO4K systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Mar 17 12:10:11 VERO4K systemd[1]: Failed to start Load Kernel Modules.
Mar 17 12:10:11 VERO4K systemd[1]: systemd-modules-load.service: Unit entered failed state.
Mar 17 12:10:11 VERO4K systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.

Could the meson-ir module be related to this issue?

Yes after the latest update my Logitech Harmony Elite stopped working.

Hi I’ve just updated and my harmony ultimate remote has stopped working hope the fix Sam will be putting out will fix this issue as well

Same here. Stopped working too…
Same error message as previously reported.

Is there the possibility to reboot with the old kernel, until the drivers are fixed on the current kernel?
IMHO - that would be the easiest/fastest workaround.

vmlinuz-3.14.29-61-osmc is still on the vero4k. How can I boot into it, instead of the -68?

You should be able to update now and find the issue resolved.

Thx. Will check it out. So far, unable to access to
Will try a little later.

We switched to our internal real-time mirror until mirrors synchronised.
I’ll switch back to the CDN in about 20 minutes and you’ll be able to grab it then.


Ok. Thx.

Getting a update error error installing will switch have coming to eat and try again in an hour

Just reboot and update again. The files are on the CDN now.

I have updated to osmc 3.14.29-69-osmc but the remote is still not working

Just updated again, loaded the kernel, rebooted - and it works.
Thanks again SAM for your commitment. really appreciated :slight_smile:

Try check for updates again.
If you changed any settings after updating to try and fix it, you may need to revert these / make sure your remote is set up in My OSMC.

No updates available.

I did not make any settings changes.

Just updated glad to report harmony ultimate is working ok thanks Sam if any of you still have a problem reboot and try again

All working now. The remote decided to play up at the same time! had to resync it to the blaster.

Thanks for the quick fix.

Big Thanks !! it now works again.