Last Update CEC Conflict on Vero

Hi all,
I did the the last update yesterday and it excited Kodi and installed then restarted. Since then I have had 3 crashes all showing a sad face on the screen 2 reboot after a period of time and the last had to pull power cord as could not even ssh in to reboot. Will try and to get some logs up soon. Is any one else having this problem.
Tried the upload load all logs on vero and it spat out this link
Update Crashed again unresponsive for 10 mins finally crashed with SAD FACE icon then rebooted its self.
Should I do a clean install ?
Latest logs with debug on and restart

When is it crashing to a sad face exactly ? Does it do it when you are trying to use Kodi, or while Kodi is starting up ?

If the latter, does it do it when you first boot up after a power off, or was it directly after you installed updates ?

If you leave it when you see the sad face, does Kodi then load again after 10 seconds or does it keep reverting back to a sad face ? (Let it try 2-3 times to see what happens)

I do see a lot of CEC errors in your log so the crash may be related to that, in particular

ERROR: CecLogMessage - failed to find a free logical address for the client

Could you try temporarily unplugging all other HDMI devices from your TV (or AV receiver, if that’s where you plug the vero in) and see if it still crashes ?

It’s possible that if CEC is the cause of the crash that some other HDMI device is preventing it from allocating an address on the CEC bus.

Have you changed any CEC settings in Settings->Input->Peripherials ?

The original Vero release of OSMC did not have working CEC in it so if you have a CEC issue with your setup you may not have noticed until after the update that enabled CEC support.

PS your second log file just says ‘Hello World’ ? :smile:

Hi DBMandrake
The crash is happening at random atm, will attempt to play movie and it will show the spinning after min or so SAD face. The restart is fine and is fluid until trying to play media or go into OSMC Menu.

This was a bit of both the first time it reverted back to sad face, the second time it rebooted its self then came back to Kodi and worked for a few minutes then locked up again.

CEC was not a problem until this latest update and it didn’t cause a problem with the error message as I posted in another thread about CEC were when I removed the Panasonic Blue ray player CEC worked fine but when plugged back in the error messages continued but did not effect the Vero at all. Should be able to have 2 CEC devices connected at the same time as we have had 2 before, So it points to Kodi or Vero being the problem. I will try to remove it but as my wife and son use the blue ray often it can’t stay disconnected. I don’t think its CEC have strong feeling something is corrupted.

Crap sorry will try that again.
Thanks for you reply
Cheers Peter
Here id the missing Log file:

Hi again,
Well did some more digging around and had lost movie art and Tv art, movies, TV and music all unresponsive to remote press. Tried to go into OSMC Setting unresponsive. Removed Panasonic Blue Ray Player to free up CEC, Rebooted and now all is working again. Have access to all of the above again.
So at this stage CEC is the problem that needs to be solved, as my wife and son use the Blue Ray player a lot leaving it unplugged is not an option. So I would like to know why Vero and Panny BR Player can not co-exsist while plugged into the Samsung ES8000 LED TV ? How do I go about fixing this or is there a way of turning off CEC in Vero manually, again not ideal as I think that they should be able to work together as did the Panny and the Onkio Sound system did before I gave it to my brother ?
Any idea guys and gals as I don’t want to be having to do the cable shuffle every time we change devices.
Again Cheers,
Latest Log from Restart Vero only to TV no other CEC devices:

Can you try changing the port number in the CEC settings?


Hey Sam,
Sure can I’m on the CEC settings now it has blank as default ATM what should I input there COM port 1 ?
There is also Physical address 0 not to sure what this should be but 0 ATM

Not sure if this will work, but in the Physical address box can you try putting


Where x is the HDMI port number of the TV that the Vero is plugged into so for example if it’s in HDMI3

Then try restarting and make sure CEC is still working, if so then try it with your blu-ray play connected again.

Edit: You might not want the dots, in which case also try it without dots such as 3000.

Hey DB,
Tried that and restarted and CEC still worked on Kodi. Plugged the Panny back in and it stopped working again and tail in terminal shows error back again.

Edit: just saw your edit :smile:
Edit 2: No still no joy with 1000 in Physical address EG HDMI 1 should it just be 1 or is there a rule to follow like ip address

I was looking at HDMI addressing from here for example:

Could you try something else. Press the defaults button then OK, if you come back in you should now have an ‘HDMI port number’ - set that to your HDMI port number then choose OK and see if that helps.

When the blu-ray player is plugged in and causing a problem is it turned on or off ?

Have a look at the following posts in this two year old thread:

DB I tried the default and restarted but no joy there it looks as if you are on to it in regards to some of the units don’t work nice with CEC and bad firmware on units.

Yes the blu-ray player is off.
Its 1.21am here and I have to bail to bed for work tomorrow but will try to follow this up in the arvo now that I know what is causing the problem. I changed the topic so people don’t get the wrong info sorry guys and thanks for the help so far cya tomorrow night :wink:

Try it with the blu-ray player turned on and see if it works OK then.

I’ve been doing a bit of reading about CEC issues (it’s generally worked fine for me so I’ve never had to troubleshoot it) and it seems that some HDMI devices when turned off can interfere with CEC on other devices connected to the TV as the CEC pin on each HDMI port is wired directly together in the TV. This was apparently a major problem with some set top boxes over the years.

A workaround is to disable pin 13 (CEC) on the HDMI cable of the device that is interfering, (in your case the blu-ray player) assuming that you don’t need CEC features for that device. Apparently this is a common enough problem that people even sell adaptors which disconnect pin 13, such as this one:

Hopefully that would be a last resort though.