Latest OSMC update for Rasberry Pi breaks HDMI-CEC

Newbie here to the forum. Tried out OSMC and loving it!

Just one thing, the lastest update to version February 2016.02-4 breaks my HDMI-CEC. The thing I see in System - Input Devices is that the peripherals is greyed out and I’m unable to activate this option at all anymore.

Anyone else having this issue and any idea how to fix?


I have the same issue, just created a thread about it.


1 Like

I have the same issue after last update with Sony Bravia CEC not working

How can i get the log ?

When I turned on the TV just now, I had a notification about available updates waiting. As I’ve done a few times before, I used the TV-remote to select “Yes” and OSMC installed the updates as usual. When Kodi was back on screen, the TV-remote no longer worked to control Kodi and scanning for new Anynet+ devices only found my PS4. Tried restarting Kodi, and also tried rebooting to no avail.

Anyone else have this problem? Or even better, a solution?

I’m having the same issue here. Updated and now my Samsung TV doesn’t see the HDMI-CEC anymore and the Peripherals option in the System menu is greyed out in OSMC.


1 Like

Try unplugging the TV at the mains and plug it back in.


I can confirm the peripherals section is grayed out here too. I had a vague recollection that was where the HDMI-CEC setup stuff was.

@CaNsA looked and found this:

13:47:19  13.776396 T:1957311024   ERROR: Unable to load, reason: cannot open shared object file: No such file or directory
13:47:19  13.776648 T:1957311024   ERROR: Initialise - failed to initialise bus cec

@sam_nazarko don’t think that will help in this case. is nowhere to be found, but rbp2-libcec-osmc is installed. is there tho.

You don’t have

What does ls /usr/osmc/lib | grep cec show?

I need to know which device you’re running OSMC on. I just did an upgrade on my Raspberry Pi 3 and it looks OK.

Its on a Raspberry Pi 2. The following files are available:

Seems Kodi still wants 3.0, but 3.1 is installed:

  Installed: 3.1.0-1
  Candidate: 3.1.0-1
  Version table:
 *** 3.1.0-1 0
        500 jessie/main armhf Packages
        100 /var/lib/dpkg/status

You have the wrong version of libCEC installed. Did you install a Kodi Krypton build before?

cat /etc/apt/sources.list

Please also run:

sudo apt-get update && sudo apt-get install --reinstall rbp2-libcec-osmc=3.0.1-16

I’m having the same issue with my Samsung TV. I have RP2.

I didn’t install any Krypton build before.

Nope, this is a fresh install. Haven’t had anything else installed prior.

Tried installing libcec 3.0 again as you suggested:

E: Version '3.0.1-16' for 'rbp2-libcec-osmc' was not found

My sources.list:

deb jessie main contrib non-free
deb jessie-updates main contrib non-free
deb jessie/updates main contrib non-free
deb jessie main


I see the issue now.

I built a new version of libCEC today, including our first stab at Vero 2 libCEC implementation. When I pushed 3.0.1-16 to the repository, it was superseded by 3.1.x which we included for Kodi Krypton builds. I moved that out of the staging repository, and added it to gmc’s repo instead, but it was already sitting in the incoming/ directory, so a refresh of the Release repository pushed the newer version instead of our 3.0.1.x bump with a fix for repeated power on of an AVR.

I have updated the repository now (it will take approximately 45-50 minutes to synchronise). After which you will be able to run these two commands to resolve your issue for Raspberry Pi 2:

sudo apt-get update
sudo apt-get install --reinstall rbp2-libcec-osmc=3.0.1-16

Alternatively, you will be able to run these commands on Raspberry Pi 1:

sudo apt-get update
sudo apt-get install --reinstall rbp1-libcec-osmc=3.0.1-16

Let me know when this is working again for you.

Thanks for reporting


I have the same issue after last update with Sony Bravia CEC not working

Excellent! Thank you for the quick resolution. Will wait a little while and then try to install libcec 3.0.1 again. Will let you know how it turns out.

Excellent. Fix worked for me!!

Thanks for the fast reply.


Successfully downgraded libcec and everything is back to normal. Thanks again for the quick resolution!