Latest supported PHP version

#1

Hi everyone!

I’m wondering what is the latest supported PHP version?
If latest OSMC version is based on Debian Stretch, is it PHP 7.0?

The reason for asking is that I have NextCloud installed and it has recently been giving me a warning about PHP version being too old.
According to this, PHP 7.0 version security support already expired so it would be good to upgrade.

#2

This is how i did it:

1 Like
#3

Sweet!

I’ll give it a go as soon as I figure out how to save/backup current PHP settings and make Apache use 7.3 version.

#4

For security reasons, it’s better to stick with the PHP version in Debian.

PHP 7.0 is the current stable version; and security fixes are being applied regularly.

#5

Dear all,

any update on that matter? I have Nextcloud 15 running on the pi 3b+ under OSMC and cannot update to 16 due to php required 7.1 min.
Don’t know if I shall search debian forums for this information maybe?

#6

There will be a new version when we move to Buster, but this is some months away.

#7

Thanks Sam, I’ll wait for Buster then!