Latest update broke hifiberry digi+ again!

I’ve had the issue with the sound disappearing on the January update. I added dtparams=audio=off and everything came back as it was.

I’ve done another update today and the same thing has happened. Again. No Hifiberry digi+ sound through my amp. The SPDIF isn’t lit as it should be.

I’ve tried taking the command out. Didn’t work.
Tried changing it to on. Didn’t work.

I’m all out of ideas.

Does anyone know if there are any other solutions?

Here’s the original thread I found:



PS: I have an RPi B+ using optical out on the hifiberry digi+

Why would you do this two steps? Do you know what you do?
To get any thirdparty DAC working you first need to disable the internal DAC and then you would need to ensure that the right audio sink is chosen.

What update have you done? OSMC or Debian packages?

Provide some logs if you are not able to fix it with dtparam=audio=off to config.txt, reboot and then reselect the audio sink.

Thanks for replyinf Fzinken.

I tried the commands to revert from the previous situation of the sound not working after update. dtparam=audio=off was enough to get the audio working again.

I have OSMC App set as soundcard overlay: hifiberry-digi-overlay and the system audio settings picking ALSA hifiberry and the passthrough as SPDIF. These settings haven’t changed at all.

I’m currently running OSMC 2016-1-1 kernel, kodi 15.2. I’ve added debug logging.

Here is my debug log if it is of help. I set it to specifically check audio.

There is no optical light coming through the lead so there is nothing coming through the board. Is it possible the board has ceased to be?
(hope it’s ok).

Thanks again,

Thanks, but that’s only the kodi.log. Please upload complete logs (easiest way just in ssh grab-logs -A)

Thanks again.

Logs are up.

I spent some time playing around with things but to no avail. So I decided to copy my home folder and reinstall from the Dec 2015 update.

Everything works a treat. Here’s the logs for now. for comparisons

I’ve set the machine to not update so the problem wont come back for now.