Latest update has created issues with MCE remote

So, freshly installed the July version using the OSMC installer on Friday, got everything cooking nicely. Did the October update, now every time I press a button on the remote, it’s doubled. No issues if I plug a keyboard in. I have tried disabling and re-enabling the remote and switching it off and on again.

PI3B (no plus), pukka MCE remote (not a clone), OSMC skin

Any thoughts and help gratefully received.


***** UPDATE ******
It’s not doubling, it’s “+1ing”. If I press the remote twice quickly, the selector moves 3 times. 3=4 and 5=6.

Are you using a TSOP IR receiver or USB receiver? If the latter, try turning off MC6 decoding under Remotes.

Hi Sam,

Thanks for the reply. It’s the black IR receiver. I tried turning off RC6 in remotes, but it didn’t change anything.

I’ve updating the original post too, seems it’s not doubling, just adding 1 to each “set” of clicks, so if I click once there’s 2 moves, two clicks three moves, three clicks four moves.

Sounds like both the RC6 decoder and a remote profile are active.

Doesn’t seem to matter if the Disable RC6 box is ticked or not. :frowning:

I plugged in another IR unit (an old one with no name, but I think it was in a Hauppage kit) and that works fine, and I remembered I had the app on the phone and that works fine too.

I’ll have another look at this when I get the next OSMC.