Latest update issues

Hello team,

I recently went through and customized all of OSMC as I like it, and ran an update (silly me, no backup) and this caused the good 'ol sadface box. I thought to myself hey it must be an incompatibility with something I’ve installed, or an issue with my install I was using. So I ran the install from the mac side, popped a new install on an SD card, let it do its thing, and then updated to the latest build out tonight.

Upon reboot after the update, sadface box. I’ll run through what I’ve done to attempt to prevent this, but still encounter it.

Attempted on several different SD cards Sandisk SDHC 64gb class 10, Sandisk SDHC 16gb class 10, Sandisk SDHC 8gb class 10, Microcenter 8gb class 4, Microcenter 16gb class 10 SDHC, all providing the same result.

I attempted the Pi2 sd card driver posted about an hour ago, and this did not resolve the issue.

The only change I made, and only on one of the above mentioned card installs, was change the root password to ftp some files over. But again, that was only on the initial install on the 64gb SDHC class 10.

It seems no matter how I go about it, I have been unable to get to the latest stable Pi2 build without this error. I see no posts on the blog regarding it, no stickies about it under Pi2, and nobody else seems to be having this issue. So I am curious what could be causing this for (possibly) only me?

Happy to provide logs as necessary

Hi can you please upload these logs so we can take a look?

sudo journalctl | paste-log
```

I suppose I take that back. I ran the command under one of the cards that still has the error and received:

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Jun 11 23:03:07 2015 from 192.168.1.131
osmc@osmc:~$ journalctl | paste-log
No journal files were found.
http://paste.osmc.io/garebeqoji
osmc@osmc:~$

Hmm…

That is my fault. Run the edited command (sudo journalctl | paste-log) instead.

Doh, I overlooked that as well.

http://paste.osmc.io/aqucotasoh

It is worth noting that log is from my customized install. The fresh install I had tried ~20 minutes ago was overwritten in an attempt to set up something in the meantime.

4AM here, easily done.

A few things:

  • It looks like Kodi just keeps trying to restart. Uploading /home/osmc/kodi/temp/kodi.log will help too.
  • You seem to be using some VPN service.

Jun 11 23:03:43 osmc rc.local[276]: Thu Jun 11 23:03:43 2015 RESOLVE: Cannot resolve host address: ca.torguardvpnaccess.com: No address associated with hostname

Because you have the ‘bring up’ in rc.local, I suspect the network is not ready when it tries to make a connection. Would a lack of a VPN connection break Kodi for you? (depends on your configuration)

You should look at setting up a systemd script to set up VPN. It should run after connman.service and before mediacenter.service.

Kodi log will help

Sam

Pastebin for kodi.log: http://pastebin.com/akuMBsP4

I disabled the VPN and attempted to boot from the same system I provided you the log from to no avail - before realizing the issue still occurs (albeit with no current proof) without the VPN portion (and without openvpn installed) on all of my fresh installs and updates I had tried.

Not that this matters much, but heres the new log provided after commenting out the VPN and rebooting: http://paste.osmc.io/udosuyemey

And the kodi.log after disabling the VPN: http://pastebin.com/Wxx3yHjc

23:16:19 T:1956675584 ERROR: SQL: The table does not exist Query: SELECT idVersion FROM version

Do you have MySQL database setup? It seems it’s unable to find out what database version you have, which may indicate an incomplete database.

If it was a connectivity issue (connecting too early), that would’ve been a different error. If you remove the MySQL connection settings from advancedsettings.xml and see if Kodi then starts, that will indicate the cause of the problem

Sam

Sam, terribly sorry to have made ya work like that at 4AM, turns out hey, I have the ability to read logs too -.- deleted the advancedsettings.xml pointing to a custom MySQL database that I currently don’t have up and running right now (switching around the cubox.

All’s good.

Edit: I’m also terribly slow, you beat me to it.

1 Like

Cool, glad it’s working.

If you’d like to help me out, I’d appreciate it if you could test the new SD card driver. It seems you don’t mind a bit of tinkering.

Sam

Hey definitely. Throwing it on as soon as I throw my .img back on the SD card for the living room.

I’ll throw a post up after a day or two of using it in the sticky with some feedback.

Side note, have to say you are putting together the best distribution out there for this. I’m not just using it in one room, your distro is genuinely powering all 4 TV’s in my household. I know everyone says it in passing, but genuinely thank you for the work you put into this.

2 Likes