Latest upgrade has caused Jerky Live TV playback

#1

I’m running a Vero 4K+ as my main media player. The best device I have found for playing 4K HDR material with Dolby Atmos. Thanks !!

After a recent upgrade to 18.3.0-11 (I think it upgraded on 20/6/19) I now have jerky playback from my HDMI encoder which routes through Tvheadend .

My system comprises a Synology Server which supplies all my movies and TV shows.

I have a HD HomeRun Quatro and a HDMI encoder which feeds into Tvheadend (Running Libreelec on a RPI3) supplying the Vero 4K and other media players with live TV.

The HDMI encoder takes my live Sky TV output and pumps that into Tvheadend. No stutters / jerky playback, all running silky smooth until the recent upgrade.

After the upgrade when I play the channel showing the HDMI input (SKY) it now stutters terribly. This is easily seen on the Sky news ticker. All the other channels from the Homerun (SD&HD) still playback fine.

I also use a generic 905X device running COREELC and a RPI2 running Libreelec and these devices still playback the HDMI encoder stream from Tvheadend totally fine. just as the Vero 4K did last week.

Log when playing TV which produces jerky playback

https://paste.osmc.tv/uwiloxunuq

It’s strange why the Sky channel from the HDMI encoder now stutters while everything is OK yet the same output to my Libreelec and Coreelec devices still works fine.

Any ideas? Thanks

#2

Does this affect recordings too?

#3

Just recorded a bit of sky news and played back the recording which is fine.

#4

Noticed from the June Blog there were TVHeadened fixes. Perhaps some of the changes have had a knock on effect which are producing the stutters.

If I watch LIVE TV as described above I now get stutters but if I record LIVE and play it back or time shift it plays back fine.

Shall I rollback to the May update and see if that fixes the problem?

#5

Didn’t you mention that you’re running TVHeadend on a separate device though?

Sam

#6

Yes my Tvheadend server is on a different device. I thought the changes might be how the 4k+ receives the stream ‘from’ Tvheadend

#7

No – it’s only for TVHeadend when installed on Vero directy.

Do you know how to use SSH? I have an idea what this may be.

Sam

#8

Thanks

Yes I can use SSH (to a point!)

#9

OK, before that: is this channel available on DVB-T2 in the UK?

Can I just tune in to Sky News (don’t even know we still get that) to reproduce the problem?

Sam

#10

I’m in the UK but this is not a freeview channel. All the freeview channels work OK before and after the upgrade.

I also take the HDMI output from my Sky box and feed it into an external HDMI encoder. This generates a H264 stream. Tvheadend see this as an IPTV channel. Basically whatever channel I have on my Sky box is then converted to a local IPTV H264 stream. I mentioned sky news as this has a scrolling ticker at the bottom and immediately highlights stuttering. Hope this make sense.

As mentioned last week before any upgrades this all worked spot on!

#11

Got you.

I’ll need a bit of time to look in to this as I’m currently on holiday, with limited testing capabilities. I will get back to you soon.

#12

Of course have a great holiday :smile:

#13

Great – thanks for your understanding.

Sam

#14

@Chakobsa Being nosey. What HDMI encoder do you use? Is it good value for money?

#15

I use an Oupree (OPR NH100N) which coverts HDMI (from Sky) and coverts it into a IP stream. This allows me to view Sky on any Kodi box. Well it did until the last OSMC upgrade:rofl:

#16

A bit more info on this.

I downgraded to May 19 release and problem persisted, I downgraded to April 19 release and problem has somewhat gone but there is still a slight judder. So something has changed in OSMC.

Also to reiterate if I record the IPTV channel in OSMC and then play it back the play back of the recording is totally smooth in June 19 release as it is in April 19. Does the playback of the live stream use a different player?

The IPTV channel plays 100% smooth with coreELEC with 905x box

Thanks

#17

The same player is used.
Please update again and post new logs

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

#18

I have updated as requested

When I now play the IPTV stream it shows it is trying to play at 100fps. It is smooth for a second then stutter then smooth. If I playback the recording it shows 50fps (as it should be) and all is good.

The logs show me playing the LIVE channel, stopping and then playing a recording.

https://paste.osmc.tv/uqawajifay

#19

@jahutchi – I wonder if this is caused by one of your FPS patches.

#20

I think I have solved this.

Reading the logs it still showed it wanted to play the recording also at 100fps.

I looked closer at my IPTV encoder and although I haven’t changed any setting since I installed it I changed the GOP setting from 25 to 50.

This has resulted in OSMC playing the live stream at 50fps and now all smooth again. Weird how openELEC always played the live stream OK and a recent update in OSMC changed something??

Anyway problem now solved. Thanks for a brilliant piece of kit!