Leia Won't Play Videos From SMBv1 NAS

After upgrading my Raspberry Pi 3 B OSMC box to the Easter release it will not play video files from my SMBv1 NAS share. I can see the shared files but when I try to play them the screen looks like it is trying to open the file but then stops before anything plays. It worked fine on the previous OSMC release. I’ve tried re-pairing the NAS to the box, but no change. The NAS box I’m using, Addonics NAS40ESU, cannot be upgraded above SMBv1. Thanks for any suggestions you might have.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Any idea when OSMC is going to release a RPi 3 disk image for the Easter update so I can test on a fresh image?

Images should be available in a few hours. But why don’t you supply a log so this can be resolve without a re-install? It’s probably a SMB version mismatch and won’t be hard to fix.

Don’t really have the time to do that. Faster to just test a fresh image, and if it is an incompatible addon doesn’t waste your time either.

Are you serious? Posting logs would not take near as much time as re-installing, and if it’s a SMB version mismatch like I suspect, re-installing won’t fix your problem.

1 Like

The images are already available.

Where? Not here: Download - OSMC

That happens when you have large logs, please reboot twice. Then try to access one of the videos again. Then post logs.

Have rebooted multiple times since the update first released. No joy.

You mean you can’t post logs, or the SMB problem happens? Can you ssh into the system. If so, try

grab-logs -A

and post the link.

I seem to be having the same issue as OP. Unlike them I can supply logs. I’m using a RPi2 though (I think).

https://paste.osmc.tv/xowefajoju

Oddly, a couple things here and there will play. Mostly in my Movies share.

Please remove the banned addons and see if it fixes the issue. Otherwise repost debug logs once cleaned up.

It’s Leia. I just downloaded and setup the fresh disk image from your Downloads section, and it is doing the same. I’ll post the log file after I get back from dinner tonight, or early tomorrow.

Will do once the TV is free.

Is there an easy way to remove all non-stock addons without resetting the entire configuration?

No quick way really, either manually remove them or reset the whole config.

Have you set SMB max/min protocol afterwards?

I think I got rid of any problem addons. Is there a way to check in the logs?

https://paste.osmc.tv/teralovajo

Here’s another attempt.

In reference to the other reply, my SMB min version is blank and MAX is 3. I could try setting them both to 1 and see if that helps.

Suggest to try that

No luck setting both to V1.

Unless you have some other suggestions to try, I don’t have a very complex config. I could try resetting to defaults and then testing again.

My NAS box is a KD20 Shuttle Global for reference.