Leia Won't Play Videos From SMBv1 NAS

I think I got rid of any problem addons. Is there a way to check in the logs?

https://paste.osmc.tv/teralovajo

Here’s another attempt.

In reference to the other reply, my SMB min version is blank and MAX is 3. I could try setting them both to 1 and see if that helps.

Suggest to try that

No luck setting both to V1.

Unless you have some other suggestions to try, I don’t have a very complex config. I could try resetting to defaults and then testing again.

My NAS box is a KD20 http://global.shuttle.com/main/productsSpec?productId=1629 for reference.

Can you upload debug logs with SMB1 set as max protocol only.

Not sure if that really helps. So investigating your issue most likely would be the best. Generally my suggestion if you really want to keep SMB1 to swap to fstab based mounts as that would be more reliable.

https://paste.osmc.tv/ozazoqoxoh

Both SMB min/max set to 1. No change. I had no idea fstab was an option. I just found the wiki page and will try that. Configuring fstab based Samba share mounts

It’s not only an option, it’s the best choice. You also can check autofs if you like.

Ok. Gimme a few minutes to reconfigure things and I’ll report back.

Thanks for all the help!

As you were using Name instead of IP Address for your server. Did you try to change that and using the IP Address to add the server?

Apr 24 22:04:27 KODI mediacenter[318]: resolve_hosts: Attempting host lookup for name HYPERION<0x20>
Apr 24 22:04:27 KODI mediacenter[318]: resolve_hosts: getaddrinfo failed for name HYPERION [No address associated with hostname]
Apr 24 22:04:27 KODI mediacenter[318]: map_errno_from_nt_status: 32 bit codes: code=c0000001
Apr 24 22:04:27 KODI mediacenter[318]: smbc_stat(smb://OMNINAS/disk/TV%20Shows/Bering%20Sea%20Gold%20Under%20the%20Ice)
Apr 24 22:04:27 KODI mediacenter[318]: SMBC_server: server_n=[OMNINAS] server=[OMNINAS]
Apr 24 22:04:27 KODI mediacenter[318]:  -> server_n=[OMNINAS] server=[OMNINAS]

While it seems the name lookup finally works but then the issue is in SPNEGO

Apr 24 22:04:28 KODI mediacenter[318]:   NTLMSSP_NEGOTIATE_KEY_EXCH
Apr 24 22:04:28 KODI mediacenter[318]: SPNEGO(ntlmssp) login failed: NT_STATUS_WRONG_CREDENTIAL_HANDLE
Apr 24 22:04:28 KODI mediacenter[318]: SPNEGO login failed: The supplied credential handle does not match the credential that is associated with the security context.
Apr 24 22:04:28 KODI mediacenter[318]: Doing spnego session setup (blob length=42)

You could try to add

client use spnego = no
client ntlmv2 auth = no

to .kodi/.smb/user.conf and restart Kodi to see if it makes a difference

Yes, I set v1 as min and v3 as max.

Log has been uploaded to:
https://paste.osmc.tv/izijavafet

If your server only supports SMB1 suggest to try Max v1

That logs don’t have debug (with specific SMB logging) enable so they don’t show detail of the issue.

The download should be available there and via the installer.

So how do I do that? I followed your directions at: https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Enable Debug generally and then “Verbose logging for the SMB library”

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

Log with component level SMB logging turned on: https://paste.osmc.tv/kayizotoju

No difference after setting both to v1.


Reply to below response. I cannot post any more new ones today. You guys cut me off at 16:

"Nope, fresh install of your RPi3 disk image. Added my NAS and that’s it.

I enabled debug logging and SMB component level logging, rebooted, tried accessing video file on NAS, and sent log through My OSMC. That’s the url it gave me."


Still “banned” for 3 more hours from posting. What a stupid rule!

Thank you, bbaydar! Switched my NAS share over to autoFS, and it is working great now. :+1:

Really strange, seems debug only active in kodi old logs and there is no try for SMB access in that one.
The current log is not debug enabled.

This looks strange

2019-04-24 20:21:01.564 T:1793061600   ERROR: GetDirectory - Error getting zip://smb%3a%2f%2faddnas%2fshare%2fskin.confluence-3.0.39.zip/
2019-04-24 20:21:01.739 T:1793061600   ERROR: Read - Error( -1, 103, Software caused connection abort )

Do you have your profile on Samba server?

Upgraded your user to basic so you can post again.

This is really strange why a fresh install reach for Addons on SMB.