LG and AVR simplink (cec) curious problem and solved

Hi, just to report about a rare problem I had where the Vero 4k+ seems to be involved.

I have CEC peripherical disabled since I got Vero 4k like 8 months ago, zero problems. Perfect player.

Two days ago I started to notice that my TV (LG Oled B6) and my AVR (Sony str dn1080) stopped to work on hdmi arc, no sound from TV. I did several tries disabling and enabling hdmi cec on TV and on the AVR. Also tried unplug both for more than 2 hours, no success, arc not working. I was almost going to do factory reset on avr and tv when I thought on trying to enable CEC on Vero 4k to test if cec working there. Did it and all worked, arc from TV also. Disabled it and working all ok (both times with vero 4k reboot to apply cec changes).

So seems that someway vero 4k cec was creating problems on the cec from tv to avr (vero 4k is connected to avr). Really rare problem as it just happened once in 8 months.

Just wanted to report it in case someone has a similar problem some day.

CEC is cursed.
Usually a reset of things fixes problems.

Glad you worked this one out.
Let us know if you run in to any problems


1 Like

Hi again, ten months since first post. I’m having this problem almost every day. I have CEC disabled on Vero 4k but almost every day something bugs and I lose control of AV from TV till I reboot vero 4k, also AV has problems selecting hdmi sources.

Maybe problem since last update, happening since some weeks ago.

Any idea what I could test?

My system is LG OLED B6, AV Sony str-dn1080 with vero 4k, Xbox X and my isp tv decoder connected to the AV.

If you have swapped out the HDMI cable and the problem persists you may want to consider disabling it on the hardware level on the Vero’s output with something like this…

Ordered one, thanks!

Got the adapter 3 days ago and no problems since then, thnx a lot

1 Like

There’s a command line option to completely disable CEC on the Vero 4K/4K+ via the bootloader; but this isn’t advised.