LG CX CEC Not working

LG CX CEC Not working - OSMC 18.9
I’m not sure if I changed something in OSMC config to turn it off when I was using my old Panasonic TV as I couldn’t getting working on that TV when I tried it again.
Is there a setting I might of changed on OSMC?

On the LG is recognizes OSMC as Roku but doesn’t work and there’s no way I can see to change Roku to Kodi.

I have simplink on and sometimes the TV will auto switch to playstation 4 even though the PS4 is turned completely off.

  1. LG and CEC is a real big pain.
  2. Try to disconnect power from the TV and OSMC for several minutes and then power up
  3. CEC disabled would be in Settings - System - Input

Hey mouse122,

Just a heads up. You are not alone. It knockedx out any CEC functionality thru my ARC to my Yamaha receiver. The latest TV update for the LG CX is likely the culprit, I think. I sent in a help ticket last Thursday. I will post their suggestions below, but they didn’t work for me. I think they need to push another update to fix it. If you are still experiencing a problem, maybe send in a ticket too so that they realize the problem is more widespread. I’ll let you know if I hear anything else from them.

"- Kindly perform a Hard Reset on your TV. This process will refresh the internal circuits of the TV by draining all excess build-up of static electricity on the TV that might affect the units general performance. Firstly, while the TV is plugged in and turned on, unplug the device directly from the power source or surge protector. Next is to locate the physical power button on the TV itself; press and hold the button for 20 seconds while unplugged.

  • If possible, please try to perform an Initial Reset on your TV to refresh the TV connections. Please note that this will revert the TV to its manufacturer settings and will erase all saved information on the TV such as WIFI passwords, account information and all connected devices. Before proceeding, please unplug all connected devices to the TV. Please go to your TV General settings and scroll down to (Reset to Initial Settings). If you have set up a PIN code for your TV, a prompt will appear requiring the PIN code to proceed.

In the meantime, since you have mentioned that the issue started after updating the TV to the latest software, it would be best to forward this concern to our Software Team for a thorough review. This way, they can assess the situation and provide the necessary software fix.

If you wish to proceed, please provide us the serial number of your TV, along with your contact number and address so that we can create an account here in our end where we will associate your request. The review may take up to 7 days after submission, but rest assured once information is available, I’ll let you know immediately."

Thanks for the reply!
Yeah still doesn’t work and it’s not disabled in Kodi so I’ve gave up for now.

I don’t know much about the specifics of OSMC. I can say that there must have been an update earlier this week, because my CEC FINALLY came back. Goodbye 14 extra remotes lol. I am on Version 03.23.35 now.

Hey, the issue might be caused by the auto device detection.
I captured a little clip to show how to fix it: LG CEC fix
Despite me having a LG C9 I hope this will work for you too.

1 Like

Thanks for the clip but unfortunately the CX doesn’t have all them devices to choose from.
Far right has OTT device and the problem is with CX you can’t just continue, you have to choose the exact device from a list.

There are more devices to choose after the CX update though so will have to go through them all and see if one works.

Choices are:
Apple (Tried)
Minix (Tried)
Roku (Tried)
Nvidia (Tried)
Western Digital (Tried)
Popcorn Hour (Tried)

Did you make sure that after pressing “Reset Device” you went “Back to main”?
But then again I don’t know how much the menu on the CX differs from the C9 menu.

I don’t think I did but have just now and still the same :frowning:
Other box doesn’t appear anywhere, have to choose a specific device.

Would you mind taking a photo of the screen that appears when pressing “Device Connector” on your TV? I’m just interested how it looks like.


On this screen try to choose SET-TOP BOX instead of OTT

I’ve tried them all, they all ask for a specific device.
Set-top-box options are
Sky SD
Sky Q

Okay one last try.
Just delete the settings here:

and then press yes:

After deletion, just try if CEC works. DO NOT choose “Connect new device”.

1 Like

Yeah I’ve tried that as well, no luck.

Okay apart from trying a different HDMI cable and unplugging everything from power I don’t have any further suggestions what else to try.
If CEC works with devices other than the Vero, maybe try Reinstalling OSMC - Vero 4K - OSMC

Thanks a lot for the clip, Ainsley!
This fixed it for my LG C9 as well.

Just a quick question: is there a way to have a button on the LG Magic Remote for the Menu/Context menu button (the one with the 3 rows of a dot and a line), and if the answer is ‘yes’ - how?


AFAIK there is no option to trigger the Kodi context menu by using the LG magic remote.

If you press this button on the magic remote:

You can bring up this menu:

But unfortunately, a click on Menu here does not bring up the desired context menu of Kodi. It instead triggers the same action as the Home button. The Info button however, does bring up the info menu, as you would expect.

Yep, as I suspected. I am using external usb drives to play media, and there is no way to open the context menu (in order to safely remove the drive when I’m done) with the LG remote.

Anyway, thanks again! :slight_smile:

I found out how to do it. Was right in front of my nose. We just need to use the Keymap Editor. I made a short clip:

1 Like