LG OLED B7 maybe 10bit issue

#1

Sorry to add another topic.
Watching a 4k HDR movie and after 1 hour 45 mins with the ash hitting the blue sky looks terrible, there is lots of banding.
Using the built in TV player (LG OLED B7) it looks much better. No banding, but not great either, but that is probably the source (this is remux of only the brave).

During playback:

osmc@osmc:/sys/class/amhdmitx/amhdmitx0$ cat config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off
osmc@osmc:/sys/class/amhdmitx/amhdmitx0$ cat /sys/class/amhdmitx/amhdmitx0/attr

osmc@osmc:/sys/class/amhdmitx/amhdmitx0$ cat /sys/class/amhdmitx/amhdmitx0/attr

Vero4k+ is directly connected to the tv.

Wonder if “limited” means something?

#2

Yes, it means Vero is sending limited range video, which is what it’s supposed to do.

If echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr makes it worse then it’s not a bit-depth issue.

#3

I tried swapping 8bitnow / 10bitnow and I found it hard to tell the difference. My screen goes black when for 1 second so you have to remember what it looked like before!

Maybe this is a Kodi Krypton issue, no reason to think its the Vero. Bit annoying this 10bit thing to tell if its working!

#4

Yes. Can’t be avoided, I’m afraid. My go-to test clips for bit-depth are The World in HDR (a couple of seconds in, check the sky over the skateboarder) and the start of Revenant.

#5

Today spent some playing around with different UHD players and HDMI cables. I get banding on HDMI 4 but not the port immediately below it (HDMI 3).

#6

Are both ports set to use HDMI Ultra HD Deep Color?

#7

Yes, that feature seem to auto on/off on its own.
Both show a right HDR screen (with logo).

#8

No it doesn’t. The ‘Ultra’ setting allows 10 bits at 4k60Hz. Otherwise, you only get 8 bits and therefore banding.

#9

Earlier today I had move it back to HDMI4 to confirm it was reproducible. Anyway just moved it back to 4 and it’s fixed!
I tried to disable UHD Deep colour and every time I play an HDR file it switches it back on. So it wasn’t that.

#10

Are you sure we are talking about the same thing? If it’s a UHD signal, the screen will indicate UHD or PQ whatever the ‘ultra’ setting. But with most TVs, the option which LG calls HDMI Ultra HD Deep Color can only be manually turned on/off. Roughly speaking, off means the port is HDMI1.4, on means it’s HDMI2.x.

#11

I’m sure we are talking about the same thing :slight_smile:
Most important bit is its fixed now, and related to the TV and not Vero 4K+

1 Like
#12

Probably the HDMI port giving you the problem has the icon PC assigned, just use a different one, there is annoying “feature” that automatic applies “enhancements” if you use that icon :man_shrugging:, which supposedly improves response times at the sacrifice of colour space.

I suffered that for months without have a clue of what was going on, horrible way of implement a feature.

#13

You are right sir, reproduced the issue changing the input icon (I assumed it was cosmetic). Seems PC settings expects 4:4:4 don’t get it when Vero would send less and it downgrades to 8bit. Lots of articles online. Thanks for solving the mistery!

1 Like
#14

I’ve indeed had two LG TVs with this. I wish that it was more widely documented.

1 Like
#15

You are welcome. :wink: