LG WebOS TV does not pick up OSMC Kodi

I am posting here in the hope that someone can help even though it is probably not an OSMC problem as such.

I have 3 LG SmartTV:s. 2 of them are at home and one in the summer home. The TV:s are networked obviously. Both in the summer home and back in the main house I have an RPi3 running OSMC KODI with a 1TB USB connected media drive.

The OSMC media server is recognized by the LG TV as a media source on the network and I can navigate the media files in the TV user interface and select what to view. This has worked since I got my first LG TV about a year back. All of the 3 units were capable of this also the most recent TV.

Until today… :frowning:
Now for some strange reason the latest LG 43" TV (4K display and all) stopped showing the two KODI units on the network so there is only a range of HDMI inputs to select as sources…
The strange thing is that the older TV:s still operate just fine on the network and pick up the servers.
It’s just the new LG 43" TV that acts up, but it worked until yesterday…

So now I wonder if there has been some updates made available for OSMC that can make an LG WebOS Smart TV see the Kodi media server on the network?

More likely an update to the LG I would think.

I have the same type of TV but access media files via the webos app, I think its’ called videos & photos or something - is it accessible via that?

In the home dashboard it shows UPnP sources after the inputs and if you click on it from there it opens that app your talking about.

I just tried it on mine and as soon as I enabled UPnP on my OSMC box it immediately popped up on my relatively new LG TV. I think you you need to check your network to make sure your still connected and, if your running wireless, make sure it didn’t switch over to a guest network.

So how could I enable UPnP on my OSMC device?
I assumed that all of the discovery stuff would be automatically installed with OSMC, it being a media player an all…

Concerning connectivity of the TV, it is hooked up with wired Ethernet and is working really well for streamed content like Youtube, ViaPlay and SVTPlay. No networking issues in that sense…

In order to see the videos tonight I have had to move the OSMC box into the living room and connect an HDMI cable from it to the TV so I can select a source that is visible (HDMI4). But now it is no longer networked, just available to the TV via HDMI. Now I can see the video files, but cannot update them since the OSMC box is no longer on the network…
Not a good end solution. Big step down from yesterday.

While doing this I found another big obstacle I have yet to fix in OSMC itself. It uses the default skin and it shows the video files as a long string of icons on a horizontal line across the screen. Almost impossible to find and select the correct video!
How can I change the listing such that it shows the video names in a normal list with one item above/below the other?
I have navigated around the GUI in vain trying to find a setting for this. :hot_face:

I gather from what you posted this is already enabled and what your using. It is part of Kodi, but not enabled by default, so you would have enabled it unless there is some other method i’m not aware of to share a Kodi library with WebOS (without installing extra software like Plex).

Having internet access does not mean there is access to other LAN devices or that broadcasting between your UPnP server and client is working. Did you change or update anything on any router, switch, or access point recently?

By pressing one of the direction buttons, probably up, you should get the slide out menu. If you use the OSMC remote holding down the menu button will do the same thing. In this slide out menu there is an option for “viewtype” and this is what you would change.

Yes it seems like it is enabled already in the settings. I also checked in the upnpserver.xml file that it uses port 8200.

Well, one of the media sources on this OSMC box is actually a Synology NAS on the network, which is accessed through a Samba share. And this works fine to view videos on that NAS.

In which view do you push the up button? When I am navigating the menus all that does is move to the item above or below…
I do not have a real remote, I use the Yatse remote app on my Android phone.

While looking over this tonight I found that the files and folders in the media drive attached directly to the OSMC unit are actually displayed like they should. It is just the files on the the share from the NAS that are displayed in this very weird horizontal fashion.
And it was to the NAS I copied the videos I wanted to watch…

Just to make things clear. You have a RPi that has a USB hard drive plugged into it as well as NAS that it has access to over SMB. This RPI has UPnP enabled and you have three LG smart TV’s that could access this RPi (literally) yesterday with the TV’s built in Video player. Today everything works exactly as it has before except for one TV is not seeing the UPnP server. In the period of time between when you last used this feature on this TV and when it stopped working there was zero updates or changes to any network equipment, the RPi, or updates to the TV. Is this ALL correct?

As for the view issue please post a picture. You seem to be referring to a view different than what I was thinking. I was referring to the movie and tv show menus with the assumption you were using the poster or shift view.

Pretty much so! Except I do not know if there has been some TV software update applied automagically in the meantime…
And when trying to resolve this problem I have updated OSMC via its update function so it is the latest version now.

So I have now taken photos of the TV screen for two views on both drives. These are pasted together in two images shown below such that the directory listing is in one image and the file listing inside the directory is on the other image.
The network NAS drive is on top and the USB connected MEDIADRIVE on the bottom of each image. The Directory/folder view looks like this:

And the listing of files inside the dir looks like this:

This is what I mean by the horizontal versus vertical listing.
I have a hard time understanding the merits of a horizontal view…

PS: Here is the path that brought me to the states shown above:

I am downloading videos to watch from YouTube and other places using an UBUNTU 18.04 LTS Server (no GUI on this machine, just command line interface).
On it I can edit the videos using a command line tool I have developed to remove ads and other non-wanted material.
The finished files are placed in a folder hierarchy which is then shared via UPnP/miniDlna to the network.
This share was visible together with the OSMC box on the TV until the day before yesterday when browsing for video sources on the network. But now all such network related sources are gone…

Now I have tried to connect to the Ubuntu server as a video source from my RPi OSMC box (in Kodi) and it works OK.
So this is a way to actually watch the videos on the Ubuntu server via OSMC connected by HDMI to the new TV.
But drawbacks:

  • I do not have a working remote for the OSMC so I have to use the Yatse app
  • I need to have the RPi connected to the TV by HDMI, which means I have to have it in the living room. It was placed in a cupboard before I had to get it out for testing when this problem happened and it was accessed on the TV itself via the network. Much more convenient.
  • And navigating on the TV using the TV remote is a lot better than having to get the phone out to view stuff.
  • Finally the issue of horizontal file listing drives me nuts, it makes it so hard to navigate a set of say 20-30 videos inside a folder to select the one to view.

Isn’t there some configuration file in Kodi where the view setting is stored that can be edited to set the listing vertical rather than horizontal? Seems to be no way to access any setting in the Kodi GUI for this. And it seems to be source dependent too, the new source I added for the Ubuntu share is also displayed horizontally…

From that view, press the Down key twice, and it should slide out a menu; the selected option is called “View:” and the default value is “Wide”. With that option selected, press OK repeatedly until the value changes to “List”, then press Right to get out of the menu. That will give you a “vertical” view. (There are plenty of other options for that setting - experiment and see if you like any of the others).

Did you disable CEC/Simplink on the RPi and/or TV? Your TV should send basic commands (direction, play, stop, ff, rw, exit, select) when the RPi is the active source.

As for the UPnP issue I would unplug the TV from the wall for five minutes and try again. If that doesn’t get it then it may be worth a try resetting your TV to factory defaults and see if that gets you somewhere.

Thank you!!! :smiling_face_with_three_hearts::smile::smile::smile:
This solved the problem after a bit of detective work since the pop-out menu to the left is not entirely visible. Only half of the text is visible, but now that I knew what I was after it was possible to change the view. (the item is the very first on top of the menu).

I was thinking about that as well but had not gotten to it yet. So I was prepared to use the OSMC server via HDMI4 this time. But when I hit the source select button, lo-and-behold! The two media servers OSMC and Ubuntu both showed up as sources!
I have not power cycled the TV since Monday when we had a power outage, though…
Seems to be magically working now.

On your LG TV

settings>all settings>picture>aspect ratio settings>just scan>on

This will disable overscan which is why your edges are cut off.

1 Like

It was set to Auto, but changing to ON did not change anything.
However, I visited Kodi settings and found where I could adjust the overscan to bring an arrow in the upper left corner into the image. This solved the problem. I can see the pop-out menu now.

You did not follow my instructions. The aspect ratio and just scan (overscan) are two different settings. For optimal picture quality just scan must be set to on so it displays the entire output from the video signal as would be normally expected from any HD source.

What you did is force Kodi to shrink your video signal to fit into the non-overscanned area of your TV. I would highly recommend you disable overscan on your TV and then go back to where you calibrated the screen and use the reset option to get rid of that calibration.

There are only two settings available on my TV:
Aspect ratio is set to 16:9
Just scan is set to ON (changed from Auto)

But setting it like that did not fix the overscan on the Kodi menu whereas the Kodi settings did.