Library clean causing the Vero to hang/crash

As per title, if i try to clean the library it gets to roughly 75% and stops, the Vero 4k then will not respond to the remote and i have to disconnect the power in order to reboot.



Sorry to hear you are having issues, I can’t really see anything in the log. A full debugging should be more helpful, details can found here

Thanks Tom.

Can you try deleting the database and rescraping?

Ok, deleting the database didn’t work, because it refused to update the library after this even after a restart. Eventually i had to delete all sources, then re-add them before the library would updated again.

Now as a matter of course after this was complete i ran a “clean library” in order to check it now worked, which it did, but i guess the big question has to be, is this a one off issue of a database getting corrupted, or is this likely to happen again do you know?

Since the cause of the problem is unknown, any answer you get is going to of little real value.

I can only say that I’ve been running OSMC (and previously raspbmc) for a few years on various Raspberry Pis and now a Vero 4K and haven’t yet experienced such a problem as yours. I also work in IT and know that sometimes stuff just happens and no system will ever be 100% reliable. That’s why we invented backups. Believe me, those boring backups are your best friend. :wink:

I have also been using OSMC, XBMC & Kodi for a number of years on Pi’s and android devices. I also work in IT and whilst its true what you say about backups, I have never in all those years seen a library fail like this so its not unnatural to assume, given the evidence at hand, that this points towards something specific to the combination of device and software. Even in the brief time i have had the Vero 4k i have not had a problem doing a library clean, in fact this is probably the first time i have done a clean since the April update.

Well, yet again for reasons unknown, my library has become corrupt again and i cannot perform a clean library, this time it hangs at a different point but the result is the same.

Unfortunately this now has an added dimension in the sense that the vero won’t even update the library on startup as it has been doing, No doubt it will be resolved by deleting the library and removing all sources like I did last time but i wouldn’t have thought this is something should be happening this often?

No – this shouldn’t be happening often if you are shutting down Vero correctly.

Do you have any additional applications or services on your system? They may be causing instability. If you’re using Library Watchdog, also be careful of this.


I literally have installed nothing in terms of add ons other than a subtitles service, everything else is stock.

The files in question are served from two different NAS

When you say shutting down Vero, i thought it was supposed to be on 24/7?

The Vero 4K is designed to run all the time, but it can be shut down or rebooted. I just wanted to make sure that when you do this you select Shut Down in Kodi first and wait for the front LED to turn red, instead of pulling the plug first.

I don’t think this should make a difference.


when i reboot, i do so from the kodi menu, unless it is entirely hung, in which case i am unable to do anything. i.e when i try a library clean, the whole thing is frozen and does not respond to the remote or even commands via SSH if i am logged in before the crash.

The device shouldn’t be freezing.

You should try a reinstall. Can you also confirm the Vero 4K is plugged directly in to the wall?


Ok, will give that a go, yes the Vero is plugged directly into the wall

I have exactly the same problem. Cleaning library doesn’t work
I use a vero4k with nfs share

Can you post a debug log? Does it crash under any other situation?

Hi Sam

Here the log

I had to unplug and restart the veto to unlock the cleaning



Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hi Sam

I have just done the update
I still have the problem


Your library may be corrupted then; I’d suggest starting a new library and rescraping.