Library issues after firmware updates on both NAS and OSMC

My library won’t update properly and sometimes crashes when I try. TV Shows library shows all my shows but doesn’t show any episodes at all. Under “files” I can go to all my content folders and play all my movies and episodes no problem so I am pretty sure it’s a MySQL issue but I have no idea where the problem lies.


If it is a corrupt database issue you could just change the name tag in your advancedsettings.xml so it makes a new database. This would keep all your settings, sources, etc. behind but you would net to set content on your sources (ie scraper settings) again as that info is stored in the database that you would be replacing.

I don’t use the advancedsettings.xml in OSMC there is the MySQL settings page where I give it all the info. So are you saying to change to the database name (i.e. MyVideos) to something else? And then it will just create a new one?

When you choose those options in My OSMC it creates/edits advancedsettings.xml with the information you provided. And yes, the name provided creates a database that is derived from that name. If you set it to a different name (and restart) it will make a new empty Kodi video and/or audio database/s.

Got it. Yeah, this seems to be working, bad database it is. Thanks for your help!

1 Like

I spoke too soon. Once the database was completely recreated it went back to not working. It worked just fine while it was updating.

I would recommend posting some fresh logs.

New log uploaded:

Can you please explain what is not working and what you have done when so that we can find it in the Logs.

I went to a TV Show and selected it to get to the list of seasons. It showed the “working” icon twice and then it stayed on the list of tv shows.

None of the tv shows take me to the seasons or episode lists. It just shows the working icon twice in a row and then nothing.

Suggest to enable MYSQL component logging maybe that shows what goes wrong.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for mysql components

OK. Here is the log with SMB library and database components enabled (there was no MySQL component to select).

Problem solved with a workaround of sorts. MariaDB 5 on my QNAP NAS had been updated in November which coincides with this issue. I was able to put MariaDB 10 on my NAS and migrated my database over and now it works perfectly.

Thanks for all your help, and hopefully this helps others.

1 Like