Library not finding all videos

I have a RPi2 with the latest release of OSMC (MyOSMC has this as the version number in the footer

OSMC June 2015 2015.06-1

I have a 2TB external USB HDD connected and mounted on startup (formatted as exFAT, so it will work on my Pi as well as my Mac), which is currently about half full.

Usually when I add a new movie or TV show to the HDD (either via FTP or directly copying it on by plugging the HDD into my computer), the library updates and the video is added correctly, but some of the time the video is not added to the library for some reason. This happens with some movies as well as TV shows. In one case the TV show was added to the library, but no episodes were added to it (which means OSMC could detect the folder, but not handle the files inside it I assume).

It also often happens with TV shows that are already in the library and I add new episodes to it, but the new episodes are not added to the library.

I’m using the same file type for almost all the files, but even when I’m not the issue does not seem to be affected by that. I have also checked the file permissions and they’re all set to 755, but I don’t think that applies to exFAT - if that’s the issue could you maybe suggest how I could change the file permissions to make them more open?

I don’t really know how to work around it and it’s very annoying, so any guidance you could offer would be hugely appreciated :smile:

Most likely a naming issue, see here

Most of my files are named consistently, but looking at it now it seems that most of the ones that aren’t loading have periods (.) between the words in the movie titles. Although, some of the other ones that also have periods are working fine. Either way - I’ll test that out and see if it helps - thanks!

That doesn’t seem to have made any difference. In fact, a lot of the time the file names of the episodes that aren’t working are formatted in exactly the same way as the ones that are. Same with the movies.

Any other ideas?

Yes, as we would ask for all support requests (the reason we make it a sticky at the top of the support subforums) -

Kodi allows debug logging explicitly for the purposes of debugging these type problems… We’ve done everything we can from OSMC’s side to make this as simple as possible for a user to provide these logs.

Try doing a search for the exact file name (minus the extension) on the website of the scraper that you are using.

For example if you are using The Movie Database for movies (the default) try searching for the name on

What you will probably find is that your name does not match there, possibly because it requires a year in parenthesis or similar. Sometimes it takes a bit of tweaking of naming to be found correctly.

Generally I would recommend dots as spaces to be replaced by spaces and “scene” info to be removed so that you just have The movie name with spaces, optionally followed by year in parenthesis (if there is more than one movie of the same name)

The cleaner the naming the more likely it is to find a match - after all it is only doing a database lookup on sites such as the moviedb after doing a small amount of cleanup.

OK, so here are the details:

Device: Rasp Pi 2
Ram: 1024
Installation media: SD card
Connection: Wifi
Power Supply Type: External power supply
Power specs: 2.1A 5V
Peripherals: 2TB USB 3.0 HDD (exFAT)
Storage Device (incl. Network Sharing Protocol): 2TB USB 3.0 HDD (exFAT)
OSMC version: 2015.06-1
XBMC version: 14.2
Codecs: Nothing aside from the default codecs that come with OSMC/Kodi
Audio/Video Output: HDMI
Overclocked: No
Config.txt Extras: None
LINK to uploaded logs in pastebin (must include COMPLETE Kodi debug log):

That’s everything, including the debug logs. I tried renaming the problematic files so they were just the movie name followed by the year in brackets, but still no dice. Any suggestions would be helpful :slight_smile:

15:48:52 T:1747940384   DEBUG: VideoInfoScanner: Scanning dir '/mnt/usb/Movies/Comedy/Crazy Stupid Love/' as not in the database
15:48:52 T:1747940384   DEBUG: VideoInfoScanner: No NFO file found. Using title search for 'stack:///mnt/usb/Movies/Comedy/Crazy Stupid Love/twiz-crazystupidlove-a.avi , /mnt/usb/Movies/Comedy/Crazy Stupid Love/twiz-crazystupidlove-b.avi'
15:48:52 T:1747940384   DEBUG: FindMovie: Searching for 'twiz-crazystupidlove' using The Movie Database scraper (path: '/home/osmc/.kodi/addons/', content: 'movies', version: '3.8.3')
15:48:52 T:1747940384   DEBUG: scraper: CreateSearchUrl returned <url>;query=twiz-crazystupidlove&amp;year=&amp;language=en</url>
15:48:52 T:1747940384   DEBUG: CurlFile::Open(0x6f93f6d0)
15:48:52 T:1747940384    INFO: easy_aquire - Created session to
15:48:53 T:1747940384   DEBUG: Get: Using "UTF-8" charset for ""
15:48:53 T:1747940384   DEBUG: scraper: GetSearchResults returned <results></results>
15:48:53 T:1747940384   DEBUG: FindMovie: Searching for 'twiz-crazystupidlove' using The Movie Database scraper (path: '/home/osmc/.kodi/addons/', content: 'movies', version: '3.8.3')
15:48:53 T:1747940384   DEBUG: scraper: CreateSearchUrl returned <url>;query=twiz%20crazystupidlove&amp;year=&amp;language=en</url>
15:48:53 T:1747940384   DEBUG: CurlFile::Open(0x6f93f6d0)
15:48:53 T:1747940384   DEBUG: Get: Using "UTF-8" charset for ""
15:48:53 T:1747940384   DEBUG: scraper: GetSearchResults returned <results></results>
15:48:53 T:1747940384 WARNING: No information found for item 'stack:///mnt/usb/Movies/Comedy/Crazy Stupid Love/twiz-crazystupidlove-a.avi , /mnt/usb/Movies/Comedy/Crazy Stupid Love/twiz-crazystupidlove-b.avi', it won't be added to the library.

The naming is still not appropriate.

OK I get that for the movie file names and I can work on those to fix them up.

Strangely though there are some series where it says it is skipping them because there are no new files, when there actually are new files in them. Two examples are ‘Suits’ and ‘Mr. Robot’ - any reason why that would be happening? The file names are formatted in exactly the same way as the previous episodes that were found at the time.

Any idea why that would be happening? A series being skipped and the log saying that there are no new videos in the folder, even when the new videos do exist and are in a format that is identical to the previous episodes in the series.