Library scan does not find any content on USB mounted drive

Because of other issues I went away from connecting my HDDs via NAS (no real NAS, it was my Fritzbox with USB connected harddrives),
and connected the drives locally to the Vero 4K via the USB port.
It`s mounting all drives without any issues, and also plays the content without any problems if I start the files directly from the drives.
But the library scan does not find one single film and does not create a library.
If I attach the same HDD again via the Fritzbox network, it is scanning immediately the correct files and creates a library.
The 4GB HDD is formated in ext4.

Help would really be appreciated!

Thank you and greetings

You could use path-substitution or remove your old sources & clean the library.

Add new source and navigate to root/media/“yourdiskname”/“your folderstructure”, chose appropriate scraper.

I cleaned the library already,
but how do I remove my old sources or access the root/media… file?

Thank you for your help!

If you go to video>files, or settings>media>library>video, it will list all your current sources. To remove an old source you would just highlight it, context menu, remove source. When adding the new source it would be the same as you did previously but instead of going to a network location you would select “root filesystem>media>[name of drive mount]>” and so on till you get to the folder that your adding as your source.

Enter Video menu/ chose files, there you should have your sources showing. Move the “cursor” to a source and open context menu, chose remove source.

When you have removed the sources, chose “Add videos”, Browser, there you will find “Root file system”, browse to media…

Edit: Ops seems darwindesign was quicker then me, well i think it’s good info that can stand being repeated. If another moderator disagrees, just remove my post.

Ok, I tried that.
But now that I removed the Fritzbox path as a source, I see now that it is not even really starting the library scan.
I added the HDD as my root file system, so under videos>files it shows up two times now, one time as a mounted drive and one time as my root file system.
Before I removed my Fritzbox as my root source, it would start scanning if I start ‘update library’, but wouldn`t find anything in the end.
But now the library scan indicator in the corner just pops up for half a second and closes again if I try that.
No scan, no library.

A valid video source would be a path that contains your movies, series, or music. As such a proper path would not be the entire root filesystem but rather something like root/media/drive/movies/. The sources also would need a scraper set for each one that is consistent with the media type they contain. See the following for more information.

I got it now :slightly_smiling_face:

My mistake was in the next step after adding the HDD as my root file path, when the option ‘This folder contains’ shows up…
By default it says ‘nothing’, thats why it wasn`t doing anything.
I changed it now to films (or movies, I use the German menu) and it works.

Thanks a lot for the hints :grinning: